PX-712A PIO instead of DMA

vbimport

#1

In my secondary IDE channel i have my PX-712A and a cd-rom SONY CDU5221 connected. In the BIOS both drives are UDMA mode 2 enabled. In windows XP the plextor is always in PIO mode. So i burn discs with buffer underruns. I try to change the plextor from master to slave without results. The ‘DMA if available’ it’s enable in the device manager for both drives. The cd-rom its working fine in UDMA 2. I changed IDE cables, did some registry tweaks, i even flashed plextor into an old firmware and upgraded to SP2 . Nothing worked!!! Im desperate!!! PLZ help me! :sad:


#2

Did you try to stick the Plextor on its own ide channel and remove the other cd-rom? If that doesn’t work go into device manager and delete the ATA controller and reboot.


#3

I did both solutions and none worked!


#4

Check the following:

  1. In Plextools, Drive Settings - Advanced - Enable DMA must be ticked.
  2. DMA Jumper on the back of your drive must be empty.

#5
  1. Already done
  2. Already done

#6

Please post your computer specs. You mentioned that the drives are set to UDMA 2 in Bios. Don’t think this is the prolem but it is best to leave those settings in AUTO/ AUTO Detect.


#7

Only for a Test:

  1. Set the mode jumper to Cable Select
  2. Connect the drive to the end of the cable from the computer’s IDE interface connector (first connector)
  3. Do not connect the SONY CDU5221

Only to remind:



#8

Windows SP1
Asus P4C800 E Deluxe
1024MB RAM Corsair 3200XL
Intel Pentium 4 Prescott 3.2GHZ
GeForse 4 MX 440 MSI
WD1200JB 120GB HDD
2xMaxtor Diamond Max 9 160GB 6Y160PO
PX-712A Plextor DVD-RW
DVD drive Sony DDU 1621
CD-Rom drive Sony CDU 5221


#9

In Your Bios Please check these settings. Under Main in Bios check that your Primary and Secondary IDE devices are set to Type/Auto. PIO Mode /Auto. DMA Mode/Auto. Then go to IDE Configuration / Onboard IDE Operate Mode and check that it is set for Enhanced Mode VS Compatible Mode. Then go to Enhanced Mode Support and ensure it is set to either S ATA or S ATA-P ATA Mode, Default is S ATA and should work. Your CD Rom is in UDMA 2 so I am guessing it’s a Bios setting, if not your drive may be bad. If this and the above suggestions don’t work. my suggestion would be to try the drive in another machine to see if it’s the drive or your computer. HTH. :slight_smile:


#10

fretis: please check these links:

http://www.michna.com/kb/WxDMA.htm
http://support.microsoft.com/kb/817472/

I also stumbled above this error: Win2K will always reverts the IDE channel to PIO.
When I boot linux, the drive is working perfectly in DMA mode. This happened after I tried to read in a CD that was not burned correctly (overburn didn’t work). Here a quote from the above link:

PIO mode is enabled by default in the following situations:

For repeated DMA errors. Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).

The solution is to uninstall & reboot the affected IDE channel. Win2K will re-install the driver upon reboot. Then activate the DMA in the Hardware Manager from the System control panel as decribed here:
http://club.cdfreaks.com/showthread.php?t=101616

Reboot again to make the DMA change effective.


#11

I love it when people register to respond to a thread that’s several months old and then post information that’s already widely known :stuck_out_tongue: :stuck_out_tongue:

Hehe, seriously though, welcome to the forums roger_wilco.