PX-712A Installation Problem

vbimport

#1

I just installed my PX-712A DVD writer, and whenever I put any media in and try to run it, the fine M$ O/S returns the error:
“Unable to find Fre%EnvironmentStringsW in dynamic link library KERNEL32.dll”.
I installed Windows again on another partition and tried again, but the same error. WHen I boot into safe mode, it doesn’t give me that error though. I thought it was a driver problem, but the fresh windows install breaking makes me think it’s not that. Anyone out there have any ideas? I just got it, and want to get some use out of it…hehe.
I talked to Plex-Support, and they told me it’s probably something with windows. How nice of them. TIA.


#2

@ the moment, I don’t have a clue of what the problem may be, but you will get more help with Spec’s of your machine


#3

Sorry about that…

Windows XP Home
AMD Athlon XP 3000+
Asus A7V600
1 GB RAM (333)
ATI Radeon 9800 Pro 128M
WD 100 GB HD, WD 200 GB HD

Any other info I could provide?


#4

Is this your only opitcal drive?


#5

Did you install original Windows XP Home or Windows XP Home SP1? If the former, you need to install the WinXP Service Pack 1 update.

You problem suggests certain OS files may be in a corrupted state on your HD, and the CD auto-run feature is disrupted.

I hope you did not install the OS with the processor overclocked. Also, does this problem exist even before installing any CD/DVD writing software?

Was the OS installed with the Windows CD inserted in the PX-712A, or some other drive?


#6

yeah…it’s my only drive in there right now. I have another, but I took it out to put this one as the only one on the channel.
I installed WinXP Home with SP1 on it with the other drive…I don’t think I installed it with it OC’ed…I have it set to 2.15 GhZ. That sounds exactly like what it is scan. I can’t install anything with the drive at all…Cd or DVD…very strange.


#7

If you put the other drive back in, replacing the 712A, does the problem persist?


#8

Try booting XP in diagostic mode via MSCONFIG. Lots of software including Sonic DLA will mess up the OS and drive letter assignments when the media tries to mount.

If it works in diagostic mode, try without startup items (uncheck the box). If it don’t work, it is probably a service loading and scrambling something else. Selectively disable the services to find the conflict. If it does work, selectively disable your startup items via MSCONFIG to find the culprit.


#9

That’s the really strange part. I went through that with Plextor Tech Support. I restarted with nothing on boot (through MSCONFIG), and the same problem. Then, when i restarted in Safe Mode, it worked fine. I turned off a bunch of Services, so maybe one of them is causing it to crash…seems odd though.
I always had my clock speed set to 2.15 gHz which is about the recomended speed, if I’m not mistaken. Any other ideas? Thanks a bunch ppl.


#10

If you put your other drive in, does the problem continue?


#11

yeah…it does. I have heard that the VIA chipset is really weird with the way it controls the IDE channels, and that may be causing this, but I haven’t been able to figure it out. Any ideas?


#12

Try going in to the BIOS and setting everything to default. If it works in safe mode and not normal mode, it is an OS issue.

Try doing a repair on the OS from the install disc.


#13

I’ve already done several O/S reinstalls. I know that it has to be a driver problem or something b/c of the safe mode issue. I tried changing the drive to be slave on the first IDE channel, and the same thing…don’t know what’s going on.


#14

Hi Spartan

It sounds like drivers have become corrupted that are not part of Windows so repairing or re-installing Windows will not work. This happens sometimes when too many incompatible burning softwares are installed or when you try to uninstall certain software.

The best way to fix this is to do a clean install of Windows, that is format the drive and start from scratch. Use the new Plextor to install Windows and everything should be fine. Don’t forget to backup any data on the drive that you need before you start!!

Good Luck :slight_smile:
Taroth


#15

Thanks for all the help fellas. But somehow, I kept switching the drives between the first and second IDE channel, and eventually it worked. I’m really scared to turn off my computer now (especially b/c I don’t really know how I fixed it which scares me), but it works for now. Thanks again to all of you.


#16

I hope you are using 80-wire IDE cables to connect your hard drives. While not absolutely required, 80-wire IDE cables are also good for connecting optical drives, as some 40-wire IDE cables can have poor quality and cause data integrity problems at the UMDA mode 2 transfer mode used by most modern CD/DVD burners. Keep in mind, however, that 80-wire IDE cables are typically much more stiff and thus fragile compared to 40-wire cables, so even though 80-wire cables maintain better signal integrity, they may not withstand too much flexing during drive swapping. I have several wasted 80-wire cables that suffered wire breakage after a few dozen drive changes each…

While your system is working, perhaps you should do a C1/C2 error scan of your Microsoft WinXP installation CD using your PX-712A and PlexTools Pro. This can help determine whether the installation CD is causing read problems during OS installation. This is a rather unlikely scenario, though.

Since the error message you encounter references KERNEL32.dll, it may be worth comparing the attributes of this file (date, size, etc.) with one in another “healthy” system not exhibiting the same problem. The KERNEL32.dll
file in my system32 folder has a date of 8/29/2002 3:41am, size of 930,304 bytes, version 5.1.2600.1106, corresponding to WinXP Pro SP1.

The only other thing I can think of is to try booting WinXP into “VGA mode” as opposed to “Safe mode”. Sometimes, device drivers such as graphics drivers can cause bizarre compatibility problems. You can also try uninstalling the Via IDE drivers (if it is installed).