PX-708UF / No firewire recognition

vbimport

#1

Hi,

My PX-708uf is not recognized by Win XP after a system reboot. I have the drive connected through the onboard firewire connector of my systemboard. If I power the drive up (or remove the FW cable ans insert it again) while in Win XP the drive gets recognized, sometimes just as CD drive and sometimes as DVD-RW drive. The drive can be accessed and functions ok. If I then reboot the system, the drive just shows ‘Local Disk’ with a red question mark through the CD icon. The drive is not accessable.

This is what I’ve tried so far:

  • formatted hdd and installed Win XP, latest Intel .INF update and SP1a. Installed no other software!
  • tried a Gigabyte 8KNXP and an Asus P4C800-E deluxe systemboard and connected the drive through the onboard FW-400 connector
  • connected the drive through a pci firewire adapter (oxford controller)
  • tried a 4-6-pins cable and 4-4-pins cable

The drive functions ok when connected through USB, but to me that defeats the purpose of buying this drive in the first place.

Plextor Tech has been very friendly and the drive has been replaced twice already, but the problem stays with every new drive they keep sending me.

Anybody else experience this problem too, or has a suggestion? TIA.


#2

Your problem may be related to a known issue with a Microsoft WinXP driver supporting firewire. Here’s a link to a Microsoft Knowledge Base article on the subject:

http://support.microsoft.com/default.aspx?scid=kb;en-us;329909&Product=winxp

This article talks about firewire storage devices failiing in WinXP after standby or hiberation, but your PX-708UF failure is after rebooting, so I’m not sure if these have the same root cause.

To get the hotfix to update the Sbp2port.sys driver, you will need to contact Microsoft Product Support Services, according to the above KB article. I also have a copy of this hotfix, if for some reason you are unable to get it from Microsoft.


#3

common problem with built in firewire ports on motherboards. i would suggest you purchase a PCI firewire port instead of using the one off the motherboard. also if you’re using INTEL APPLICATION ACCELERATOR that could also cause conflicts with software and hardware. try uninstalling it and just use the MICROSOFT drivers.


#4

The hotfix that scan80269 kindly provided me with didn’t solve my problem. But it lead to the solution anyway because when I saw the name of the hotfix (Q329909_WXP_SP2_x86_ENU.exe) I got the idea of installing SP2 RC2 build 2138 from MS Windows update, and this fixed my problem!

The drive now shows up in Explorer after every reboot as a DVD-RW drive, and works like a charm connected to the onboard firewire connector.

Thanks for your suggestion. However I already tried this with a pci Adaptec usb/firewire combo card and a pci firewire 800 & 400 card. Neighter one solved my problem unfortunately.