[PX-708a] Plextools 2.17 crashes on DAE

I own a Plextor PX-708a, and I always use EAC to extract audio. Today, I wanted to backup a scratched CD, so I decided to use Plextools.
When I clicked on ‘digital audio extraction’ insode Plextools, Plextools crashes, but only if a CD was inserted.

My system:
ASUS A7N8X Del Rev 2.0 (nForce2), AMD Athlon 2100+, 1024 MB RAM, Windows XP SP2.

I already tried:

  • Reinstalling Plextools
  • Installing MS IDE drivers instead of nVidia SW IDE
    I also tried to install an ASPI layer (Plextools’ System Info showed no ASPI layer is used). But putting wnaspi32.dll inside the Plextools’ map and inside windows\system does not change anything: Sytem Info still says Plextools is not using an ASPI driver. (ForceASPI does also not work. After applying that program and restarting my computer, still no ASPI is installed according to ASPIchk!)

After doing those things, Plextools still crashes if I click on DAE. Has anyone an idea to solve this problem?

  1. manually remove the entire Plextor key from the registry
    HKEY_LOCAL_MACHINE\SOFTWARE\Plextor
  2. re-install

Alternatively try an older version of PTP in step #2. You may keep the v2.17 exec alongside the old version by renaming it to something like PlexTool217.exe.