Puzzle with SH-S203N on XP and Vista

vbimport

#1

[qanda]This thread is about the Samsung SH-S203N / TS-H653N. Click here to see full specs[/qanda]OK, here’s a puzzle.

TSSTcorpCDDVDW SH-203N, Version SB02, OEM SB.
EVGA 132-CK-NF79-A1 MB, nForce 790i Ultra SLI 775 A1, C73M55XECRB

Dual boot (two separate, non-RAIDed Raptors and one joint storage drive, all set as PCI/SATA, confirmed on the nForce Serial ATA controller (second entry in Device Manager).

Latest firmware updates for everything, and I have been lurking here to try to figure this out on my own, but this makes no sense to me. I have successfully updated the firmware, but no difference…

I can listen to and import CD audio. I can run iTunes and import from CD and DVD. I can play back both commercial and self-created (other system) DVDs, and can create both data and movie DVDs.

The only thing I can’t do (at all) is burn CDs.

The blank media is recognized successfully by both the Vista 64 bit and XP SP3 sides of the dual boot. Neither OS shows any problems recognizing the drive, and both sides rip successfully. Both sides burn DVDs successfully. In all cases, using everything from the OS native “burn data CD” through to iTunes, CreativeLabs, RealPlayer, RealTek, etc., the burn process fails with an “unspecified error”.

I tried decreasing the writing speed, i tried multiple media manufactorers, I checked for problems in Device Manager. I am rechecking the Master/Slave option in bios, but I think that is a red herring. Basically, I’m stumped.

Before I go trying to navigate Samsung tech support, am I missing something blindingly obvious? I must have some software conflict or something I don’t know about, because I cannot see how hardware could be recognized and perform well on all those other tasks and fail only on the cd write.

Help? Pointers?


#2

Hi and Welcome!

since you don’t have a Raid setup, could you please try if your Sata controller can be set to something like “IDE” (or similar) in BIOS setup?

Additional question: is this your only drive in your computer?

Michael


#3

Checking… (Thank you for the help!)

it is one of four drives, attached through the nvidia Serial ATA controller.

The first entry in the Device Manager under PI bus connections is the

    • ST350032 OAS SCSI Device
    • TSSTcorp CDDVDW SH-S203N SCSI CdRom Device

(Region 1, and insists on using the Microsoft 6.0.6001.18000 drivers on Vista64, andthe standard drivers as well on XP).

then the two ‘boot’ drives show up, each Raptor seen as a different connection

    • WDC WD15 00HFD-00RAR SCSI Disk Device
    • WDC WD15 00HFD-00RAR SCSI Disk Device

In the bios:

IDE Channel 0 Master [none]
IDE Channel 0 Slave [none]
SATA 1 [A0] TSST
SATA 2 [A1] ST
SATA 3 [B0] none
SATA 4 [B1] WDC
SATA 5 [C0] WDC
SATA 6 [C1] none

IDE Auto Detection [auto]
Extended IDE Drive [auto]
Access Mode [auto]

RAID [disabled]
MCP SATA -> eSATA Configuration [all disabled]
IEEE1394 Controller [enabled]
JMicron AHCI Controller [enabled]
IDE HDD Block mode [enabled]

On Chip IDE Channel 0 [enabled]
Primary Master PIO [auto]
Primary Slave PIO [auto]
Primary Master UDMA [auto]
Primary Slave UDMA [auto]
IDE DMA transfer access [enabled]
Serial ATA Controller [all enabled]
IDE Prefetch mode [enabled]

Does a SATA controller have the same troubles that a RAID controller have? (And I am not sure what to set in these settings to allow IDE mode, as it looks like the extended IDE mode covers this already…)


#4

Hi,

thanks for these detailled information.
Since all attached drives are shown as SCSI, the Sata controller is not running in IDE operation mode.

I would check these settings for further options:
Extended IDE Drive [auto] <— this looks promising
Access Mode [auto]
Serial ATA Controller [all enabled]

JMicron AHCI Controller [enabled] <— perhaps disabling for troubleshooting? I guess you have one of your Raptors connected there.

Michael


#5

Not sure, but shouldn’t optical drives be on SATA ports 5 or 6?


#6

Depends on the mainboard. This beast has an additional Jmicron aboard, I guess, that is port 5 or 6. This should be avoided with opticals :cool:

But exchanging a HDD with the drive is worth trying if nothing else works.


#7

Hmmm… the only options bios gives for any of those is Auto or Disable. It might be time for me to open up this case and see what is connected where.