PSX backup problem

Hello.

Im having problems to copy a psx cd, seems like somebody put some sort of custom copy protection (its a backuo copy) it will read on the console just fine, but I`ve tried on several diferent readers, and they all report it to be 4095 mb long, or 0.00kb long (on my computer), so, no program I´ve tried so far (clonecd, clony, A-Ray, isobuster etc…) will read anything at all from it.

Any help or guidance is very much appreciated.

PS

A-Ray will report the following:

Size 0MB
lenght: 00:02:00
sectors: 150
data tracks: 0
audio tracks: 1

Is this a copy off of a copy?

You do mean PSX and not PSX2 right, and your PSX is modded I hope as if/when you finally do make a copy, it won’t self boot otherwise.

yeah, it`s FF anthology for the ps1.

it will run on the console but I haven`t been able to find a way to read it succesfully.

Can you read the original again? Copying a copy is possible but not as long-term reliable, and there is always some loss.

I managed to read the cd with another reader and it will show a first track, audio, and a second one of 4095mb !!.

is there a way fix/bypass the toc (seems like it`s being the problem) or something at all that can be done on this case?