PS/2 mouse connector not working, help!

vbimport

#1

I recently flashed/updated my Bios. Everything went smoothly with the exception of my mouse now not working through the PS/2 port whereas it did perfectly before the Bios update. I went into the Bios to see if there was anything I could change but the only thing I found related was USB support for a mouse. It seemed to make no difference enabled or disabled, the PS/2 connection was still dead. It is a Logitech MX1000 wireless mouse with a USB plug. I am using a PS/2 port with this mouse by using an adapter plug since if the mouse is plugged directly into a USB port the accuracy of the pointer is not nearly as high, it tends to jump a bit…go figure, for an $80 mouse…the help forums for the mouse specified to use a PS/2 port to solve the jumpiness issue which worked for me now for a few months. In any case, after the successful Bios flash the Mouse does not work through the PS/2 port but does through the USB port, albeit with the same aforementioned jumpy pointer. My question is, how do I re-enable the PS/2 port to start working again and why would it have stopped working??
:sad:


#2

Have you checked DEVICE MANAGER for conflicts. I updated my bios some time back, and some of the new drivers didn’t agree with my system. I ended up having to rollback the USB drivers on mine to get my usb to work. Maybe you have a similar issue…


#3

Thanks very much for the reply Harley. I do know how to get into the device manager but I didn’t see anything wrong when I went in there yesterday. Though to be honest I am not certain if I quite know what problems to look for. Could you please tell me what exactly would constitute a “conflict” or how it would look if I did see it? Thanks!

PS. Isn’t the PS/2 port “hardwired” on the board not needing any drivers?? Or maybe I’m way wrong…


#4

It might be a case of clearing the CMOS.There might be a jumper on the motherboard for this or you may need to remove the battery for 10 mins or so.


#5

Go to control panel/system/hardware/device manager. If there is anything with an exclamation mark that means there is a conflict or problem.


#6

Thanks guys. I will take a look when I get home.


#7

Nope no conflicts detected. Starting to think the only solution might be to go back to an earlier bios since I couldn’t find anything in the bios settings to tweak to get that port working again…sighs heavily.


#8

Good luck. Just as a side note, are you using a dark colored mouse pad. I was having problems with my MX700, and found somewhere that by using a lighter colored mouse pad the problem would go away. It fixed my problems with the mouse jumping.


#9

Interesting, I am using a dark pad but I never had this problem before in all the months I was using the mouse when it was plugged into the PS/2 port…

I wonder if clearing the CMOS might work as Tim C suggested…maybe I should try that.


#10

have you tried using the latest setpoint drivers?


#11

maybe you should try going into the bios and use the default bios settings. I had a problem once where I flashed my bios which also should have reset all settings to default, later I found out that the flash had seemed to reset the settings at first sight but it hadn’t. So maybe just try to use default bios settings.


#12

Yes Mr. Brownstone, I definately did download the latest setpoint drivers, but good question! Thanks Goenigoegoe, I think I will give that a try.


#13

Just to give you all an update. I downloaded an older version of BIOS over the weekend, installed that and now the PS/2 port is working perfectly! Word to the wise…if your BIOS is working fine, don’t bother changing it!! Thanks to all for your kind advice and help.


#14

Are you sure you had the correct BIOS update?


#15

Buy a USB mouse!


#16

Has definitely missed 99% of this thread :doh:


#17

I did indeed have the correct BIOS Matth.

DJMind…please read my first post. This mouse is a USB mouse but I already explained why I wanted to use the PS/2 port with the adapter.


#18

My bad, good luck! :iagree:


#19

Hi there,
I hope your thread is not dead… I experience the same problem as attigabi. My Logitech mx1000 is not detected as a PS/2 mouse when the computer is turned of. However, if i start up the computer with another mouse connected to the PS/2 port and switch when the system is up, it works fine. It also works if i connect it as a USB mouse, switch and restarts without turning the computer off. I have tested everything I can think of. All drivers are updated, most of my PCI card has been removed to avoid conflicts, I have tested four different MoBo bios versions back in time. So far no luck. The reason I whant the mouse as a PS/2 mouse instead of the USB option is that I have a 30 feet PS/2 wire for control when whatching film on TV. Did you have SATA HDD? Raid? Could that be a problem?

I have:
MSI PT880
Gigabyte 6600gt
3com WiFi lan card
MX1000


#20

If you updated the bios did you also update all the related drivers for the MB?
IE chipset drivers? Also what make is the MB? Some of the bios sets for Asus will not work properly with certain Keyboards and or mouse. You have to use a certain bios download in order to get it to work.