Promise Ultra66 problems

vbimport

#1

I am using WinXP pro on a K7ADA motherboard with an AthlonXP +1700. I have recently plugged in a Promise Ultra66 PCI Hard-drive controller. I have updated it to the latest drivers as well as the BIOS is flashed to the latest version.

Here is my problem. When connecting the harddrive to the card (I use 80-pin ATA-100 compliant cable), the Windows never boots.
When starting the Ultra66 card detects the HD as Device 0 (it has device 0 through 3). It detects the harddrive as Fireball AS 30gig.

Now when it comes time for the hard-drive to boot the OS, nothing happens, no HD activity. It just stays there. What is the matter?

Also another problem with UDMA. MY motherboard has built-in ATA-100. I connect the hard-drive to it with a compliant cable. The post-startup screen (when computer is starting up) shows ATA-100 on this device, but windows shows it as PIO mode. This majorly sucks because every time I have hard-drive activity i get slowdowns (as it is not direct memory access). I have selected "UltraDMA if available " in device manager but it still only allows be PIO mode. What is the matter here?

Any help would be greatly appreciated! :slight_smile:


#2

if there’s a pio mode device on the same cable set ( an old cd rom player ) windows will set the entire bus to the lowest one : pio that is.

since you recently plugged in the promise card , windows has no clue that the boot device is on a external controller , but i have no idea how to tell windows that. I do know it can be set during an install/upgrade of the Operating System though , F6


#3

I dunno’ if this will help, but when I switched SCSI cards on my Win2K box it would not boot either. What I had to do was have the disks pluged into the old SCSI card and have the new one installed, but no devices on it. Windows found it, installed the drivers and after a reboot, it was useable.


#4

Well, I’ve tried that too (having HD plugged to motherboard, Card detected by windows, rebooted with HD plugged to Card) and I still get the same thing. I do remember the card was working on my old P3 500Mhz w/ WinXP Pro


#5

When HD is connected to Promise:
You need to set your BIOS to boot from SCSI first
You need to make sure your boot.ini has rdisk(0) in it for XP if it wasn’t before (if you were connecting to primary master it should be already)


#6

I’ve finally figured it out!

The hard drive I was using had a pushed-in pin, so it was only partially functional. After fixing the pin, the HD works at full speed!

:smiley: