Problems with PS2 backups

vbimport

#1

Hi
I’m having problems with a Ver3 PS2 playing copies to backup games, Mercenaries takes a long time to load up, you can go right through to the character selection screen, a short fmv afterwards then starts to load the game proper, at this point it hangs. GTA3 SA works ok but sometimes you lose parts of the background and scenery they just go blank or white.
Killzone take ages to load and again sometime you lose the scenery.
The original discs work ok.
I use Ritek G04 (datawrite Yellow discs) burnt at X2 using DVD Decrypter or Nero Ver 6.
The PS2 is quite old, using the messiah chip, don’t know which one? think it was the last one produced.
Could this be a laser problem or media?
Please help
Many thanks


#2

Sounds like you burned too fast with bad media. Try using something like Imation or some other half decent brand and try burning at 2x instead of the faster speeds. Most modded PS2’s have problems with newer media so try DVD-R for now, as it is the most compatible.

Good luck with your ‘legitimate’ backups. :slight_smile:


#3

He already said he was only burning @2x but i would try better media like verbatim and dvd-r is more compatible although my ps2 version 7 plays both and also works with dvd+r bitset to dvd-rom…
ritek can be hell just now with all different results reported by different people
all ps2 consols dont have the same lasers either some can be picky.
If you have access to another chipped ps2 you could try your backups on there just to see if the same problem occurs…


#4

My console plays Ritek fine.


#5

Never said otherwise only that ritek can be very indifferent just now…


#6

I’ve had similar problems using Clone DVD at 1X and Memorex DVD-R’s. I’ve backed it up twice and one loads just a little and then the other slightly more before it locks up.

I’m going to go buy a different brand of DVD-R’s and see what’s up. My backup of Burnout 3 plays great.


#7

This is really weird. I burned it a third time on newer media and had the same result. I checked and did the firmware upgrade to my HP 530i. I’ll try it one more time and see.

I’ve got an older DVD burner but it only burns +R/+RW . . . not sure if I can change the bitsetting to burn as a DVD-ROM on it or not.


#8

i use a pstwo slim line swap magig and smart tool and i burn using nero 6 and i use sony dvd-r in the spool pack ever back up perfect


#9

i have the similar prob with mercinaries for the ps2 and i have tried different media and different speeds i even used different progs to burn with …does anyone have any other advice