Problems with NuTech DW-082 DVD-R/W Burner

vbimport

#1

Ok, I’m using a Nutech DDW-082 DVD-R/W Burner with B377 rev. firmware, and lately, while it recognizes and plays DVDs (regular, R, RW) fine, it won’t recognize any CDs anymore. It doesn’t matter if it’s and officially pressed CD, CD-R, or CD-RW (and i’ve tried several brands and types of all), it just won’t read it.

Any ideas how to fix this?


#2

Did you change anything before this problem started to occur? I mean settings, software, firmware?

To test wether this is a Windows problem, you can try to pop in a bootable disc (like the Windows installation disc) and try to boot your system from it (this function has to be enabled in your BIOS). If it boots, it means that CDs can be read and your problem is software related. If not… well… there’s another problem. Please test this first to see what’s going on, as that saves me an age of typing :).


#3

This isn’t, unfortunantly, a windows problem. I put in two different bootable cds, and neither worked, which leads me to suspect this is a firmware problem. Any ideas on how to fix it?


#4

This happend after I upgraded firmware to B373, I believe, and was not fixed when I upgraded to B375.


#5

I upgraded mine to b373, now I did a driver to install my device in to my computer. I found my burner in device manager “other devices” and I can’t access it unless I have the driver to install. Could I possibly get a copy of yours. I bought mine in ebay not sure which software to use got so many. Did your come with USB2.0 1394? PLEASE EMAIL raventhnder@aol.com