Problems with new Benq 1670

I bought one of the I/O Magic Drives on sale from Staples over the weekend, it ended up being a 1670. I immediately flashed to FW version 1.03 (used MediaCodeSpeedEdit to modify the 1.03 FW as it was originally recognized as an ATAPI drive rather than Benq, which is normal). After flashing to 1.03 it properly is recognized as a Benq 1670. My first attempted burn was done at 8x with 16x media in an external USB enclosure, however the burn stopped writing data after a few hundred MBs, I know it was up to around 7.5x when I walked away from the computer. I then tried a Transfer Rate Test and got the result as shown below - the speed shifts down as you can see. I tried a burn at 4x with 4x media and there were only 3 slight shifts in speed which I’m guessing are probably OPC kicking in, and the resulting burn quality was very good in a PIE/PIF scan. I then installed the drive in my tower (slave drive) and it is set as UDMA mode 4, and the TRT in my tower is identical and has the same downshift in speed. I then flashed to 1.02, briefly tried a TRT (which started at around 2.5x), then flashed back to 1.03 and the TRT remains the same. I have not tried another 8x or faster burn but I will do so in a moment, however I’m assuming the same issue will exist.

So does anyone know what might be causing this other than a bad drive, or has anyone seen similar behavior? So far as I can tell it has no issues at lower speeds and also with a full 4.7GB disc the TRT will get up to about 10x or a little higher without issue, it just has the downshift in the TRT and the 8x disc I burned stopped burning data after a few hundred MBs.

So you made a TRT on a disk that stopped writing before after a few hundred MB ? Do not blame the TRT, as it read data you did not write before :). What about a TRT of a DVD that could be written without problems ?
Which media code does this disks have ?

Hi, scoobiedoobie, i’m a very, very, VERY, long time forum “lurker”, so i think this will be my first post, i encountered the same problem that you describe, but it’s only happens with the latest version of cd-dvd speed, i went crazy for a couple of days before realizing this. So… i downloaded a previous version of the program (4.51.1), and the TRT it’s perfect. i will try to post some captures of the problem later.

Ok, here it’s my TRT scan comparisons with the same disk , between cd/dvd speed versions, as you see, the 4.7.0.0 one behaves exactly that the one you posted.
The first one it’s the 4.51.1 version TRT
The second one it’s with the latest 4.7.0.0.
I suggest that you use the older version for your test, as with the latest it will give always the impression of a “bad” disk or drive.



Of course the TRT tests I’ve done are on perfectly good discs, not the disc that stopped writing. Sorry if that wasn’t immediately clear.

Thanks a lot for pointing it out, now I just need to see if my burning problem was an isolated issue. I’ll update with what I find - I’m glad you decided to post :stuck_out_tongue: . P.S. - I’ve just finished a TRT with 4.51.1 and it finished without any slowdowns (and I tested with one of the discs I tested with previously). I’ll try another 8x+ burn in a few minutes, with different media this time. BTW, the failed previous 8x burn was with Memorex-branded CMC AM3, media that has burned very well in my other burners. The burn didn’t actually fail, I walked away for a couple of minutes and the data transfer rate was at 0kb so it was basically ‘stalled’, using ImgBurn burning an ISO image. Hopefully it was just an isolated issue, but it was certainly a bad sign considering it was the first burn attempted on the drive.

Update - I just performed a burn at 8x with a CMC E01 disc (8x media) and it completed the burn without a problem this time. I’m still a little nervous about the drive although it may be ok. Between the first stalled burn and also some nasty sounding clicking noises when I first used it, I’m uncertain. Before the first burn or TRT there were a few clicking type noises, and when trying to rip a disc a few minutes later using DVD Decrypter, the drive got about 30% through before it went into some sort of continuous surge-click noises. Maybe the drive just needed a couple of dropkicks before installing it. :rolleyes:

Also, i think that you should try a burn at 16x to see if it goes smooth. I don’t know about the clicking type noises that you had, never heard that on mine while reading, but when writing, some time ago, with a bad blank, it made a click type noise and that burn was a failure, you should watch that closely. Maybe the dropkicks before installing it’s the key… :stuck_out_tongue: heh

Burned one more disc, this time I selected 16x. Burned fine up to about 14x then shifted down to 8x, although I suspect that may have just been because of the media used (CMC M01 under Office Max brand which is of poor quality in this brand). I’ll probably get a chance to try a MCC004 disc tonight.