Problems with my Sony DW-D18A

vbimport

#1

I believe I have a problem with my drive, but I want to find out for sure before I do something drastic…to sum up my problems here it goes… I can burn to a dvd r and rw fine, but when it comes to burning to a cdr or cdrw, or reading a cd of any kind… I can’t do it… is there a problem here or is this model not supposed to burn to other cd formats ?

If there is a problem can I upgrade the firmware to someother type so I can use the drive as a multiformat burner drive?

:bow:


#2

isnt ur drive a OEM liteon SOHW-832S?

what firmware u using??


#3

Hi, sasarchiver…

I know i have an OEM drive, but it says it’s a sony dw-d18a and if it is a liteon I’m not aware of this, but I was concerned about why all of a sudden I can’t burn to cdr’s anymore or cdrw’s, or play a disc other than a dvd?.. any suggestions, if I can re-install my firmware do you think that would help, or is it possible to put other firmware on this drive and if so… how do i do it?

Any advice would be a great help…


#4

Here is all the info I have after running Nero’s Info Tool:

Drive Information

Drive : SONY DVD RW DW-D18A
Type : DVD±R/RW DL Recorder
Firmware Version : VYS2
Buffer Size : 2 MB
Date : ?
Serial Number
Vendor Specific : Jun18 ,2004
Drive Letter : L:
Location : 2:0
Mechanism : Tray
Read Speed : 40 X
Write Speed : 40 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read DVD-ROM : Yes
Read DVD-RAM : No
Read DVD-R : Yes
Read DVD-RW : Yes
Read DVD+R : Yes
Read DVD+RW : Yes
Read DVD+R DL : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read Digital Audio : Yes
Read CD+G : Yes
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write DVD-R : Yes
Write DVD-RW : Yes
Write DVD-R DL : No
Write DVD+R : Yes
Write DVD+RW : Yes
Write DVD+R DL : Yes
Write DVD-RAM : No
Write BD-R : No
Write BD-RE : No
Buffer Underrun Protection

                                                                                  : Yes

Mount Rainier : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW SAO 16, RAW SAO 96, RAW DAO 16,

RAW DAO 96

Region Protection Control : RPC II
Region : 1
Changes User : 4
Changes Vendor : 4


#5

hi there, Well what id do is try it in another pc if u can, just to rule out your pc. A firmware upgrade MAY fix this, but if it worked fine before then maybe its Fooked. I had a DVDRW like this, but was viceversa, i couldnt read.write to dvd, but cds worked fine. i had to take it back to store for replacement.
Im just in from work, so what ill do is ill go and have alook round see if i can find a solution…sasarchiver

PS i have firmware for this writer, but the readme says “Use LtnRPC to reset or disable the Region Counter. Click Disable and your drive will be region free!
OEM Liteon SOHW-832S drive …VFS2 (For Belt-driven drives only)”


#6

The Sony DW-D18A = OEM SOHW-832S.VYS* - Gear Tray
The Sony DW-D18A = OEM SOHW-832S.VFS* - Belt Tray

The Sony DW-U18A = OEM SOHW-812S.UYS* - Gear Tray
The Sony DW-U18A = OEM SOHW-812S.UFS* - Belt Tray

Check what firmware version you currently have with something like Nero InfoTool or DVD Info Pro (http://www.dvd-recordable.org/wwwimgs/media/dvdinfo.htm) before doing an update & make sure to get the correct firmware


#7

Hey Everyone,

I’m new to this Firmware stuff. I have a Sony DW-D18A recorder and it burns DVD’s well and plays them fine on most players. However, a friend has a panasonic combo and it skips abotu 2mins into the homemade movie. So it seems from my reading I need to get new firmware for the burner and that may fix it. How do I go about finding the right firmware for my burner.

Thanks for the help in advanced!


#8

First, find out what your current firmware is. You can use LtnFW for that.
http://dhc014.rpc1.org/howto.htm#LtnFW

If your firmware version starts with “VF”, then stop right now because there’s nothing that you can do.

Make a backup of your current firmware. Use the LtnFW program for that as well.

Flash to VS0G… there are multiple ways to do this, but the easiest is probably to download “VS0G stock” and then run the flasher found in the package.
http://codeguys.rpc1.org/firmwares.html#SOHW-832S


#9

is it ok to use the Firmware version LiteOn SOHW-832S even though I have a sony DW-D18A burner?

And yes I had a firmware VFS2


#10

I’m having a problem with my Sony dw-u18a drive as well. I get an error code right when I start trying to burn DVD-RWs. I’m running XP Pro and the software is NTI DVD Maker Gold… here’s the error log… can someone please help me out? I have no clue how to fix it.

========== BEGIN OF LOG ==========

NTI CD & DVD Maker 6.0 6.7.0.12 (SKU-22510238888)
Start Time: Thursday, July 14, 2005, 12:21:42AM

Processor Architecture: INTEL
Processor Type: INTEL PENTIUM
Processor Level: 15
Microsoft Windows XP version 5.1 Service Pack 2 (Build 2600)
Memory in use: 41%
Total physical memory: 1047 MB
Total free physical memory: 612 MB
Total paging file: 4194 MB
Total free paging file: 4194 MB
Total virtual memory: 2097 MB
Total free virtual memory: 1997 MB

CD Layout: Data DVD
Disc Format: DVD-ROM
File System: Romeo
Bootable CD: No
Total Data Blocks: 2144532

CD-Recorder: SONY DVD RW DW-U18A (D:)
Firmware Version: UYS1
Disc Media: DVD+RW
Free Disc Blocks: 2295104
Test: No
Write Speed: 2x
Write Method: Track-At-Once
Close Disc: Yes
Leave Session Open: No

Error Code: 1005
CDB: 28 00 00 00 00 10 00 00 01 00 00 00
SenseKey:05 ASC:21 ASCQ:00

Error Code: 1005
CDB: AA 00 00 00 00 00 00 00 00 20 00 00
SenseKey:05 ASC:30 ASCQ:10

Error Code: 1005
CDB: 5B 01 02 00 00 00 00 00 00 00 00 00
SenseKey:05 ASC:30 ASCQ:06

Finish Time: Thursday, July 14, 2005, 12:23:03AM

========== END OF LOG ==========


#11

@neilalp

With VFS2, there is no newer firmware available, and you cannot use a 832S firmware. You’re out of luck.

@mmontanaa

It won’t be long before your drive’s UYS1 firmware hits 1.5 years in age. Update to a newer firmware. I’d recommend using the VS0G “crossflashing” firmware found here:
http://codeguys.rpc1.org/firmwares.html#SOHW-832S