Problems with my 1620 (B7L9) and Ritek disks

vbimport

#1

I tried searching for my exact media:

Destination Media Type: DVD+R (Disc ID: RITEK-R04-01) (Speeds: 2.4x, 4x, 8x, 12x, 16x)

but it only appears in 2 threads… an NEC thread and the monstrous 48 page media thread in the BenQ/Phillips forum. Eek.

Well, here’s the issue. I’ve been having a lot of “Failed to Write Sectors 1841312 - 1841343 - The request could not be performed because of an I/O device error.”

I’ve updated the firmware and using the latest software… still having problems. I’m using the Ritek-R04 disks and I would like to know if these disks are any good. If they’re not, what’s a good compatible disk to use with my drive?

I’ll also throw this out there… anybody else encounter this problem? If so, how did you fix it?

TIA, of course. :bow:


#2

Is this you’re first batch of DVDs with this burner? BB has some Fuji +s on sale that should work good.


#3

Had the same problem with R04’s and MCC003’s. Had 1 good spindle of each and 3 or 4 that were crap. Changed to Verbatim & Maxell and problems stopped. I would say it’s poor media. Datawrite titaniums also work well for me - never had a coaster out of 4 spindles so far.


#4

I’ve been hoping it wasnt the media… but so far, not one person has told me the disks are any good. How sad is that?

I’ll swing by BB tonight and check out those Fuji’s.


#5

You have the lates B7V9 firmware - right?

Ritel.R04 is very variable in quality as well.


#6

Is this result a byproduct of the FW or the media? Seems like the PI errors is kind of high… and why are there huge spikes in the green line?



#7

That’s a so-so burn. The spikes are there when it’s having trouble reading the disk and it’s slowing down. Did you check your device manager and see if you burner is in DMA mode Word 2 and not PIO? Also sometimes people do a clean install and things improve, but you might want to try thr Fuji + (made in Japan) first. Also if it’s sharing another device on the IDE you might try it as lone Master and see if that’s what you get. There’s also a burst speed test in CD Speed and you should get around 23Mb/sec.


#8

Burst speed test did result in 23mb/sec. I think its just a bad burn on bad media. I got some new Verbatim and Fuji’s. Let’s hope those are better. :slight_smile:


#9

I swapped 25 of my discs for 25 of these with my Dad since he just ordered some and I wanted to try them. What crap. I burn them at 8x for better burns. I won’t be buying anymore Ritek 16x media in the future that is for sure until I see proof that they ahve straightened out their quality control issues. I’m using them up since they are passable but the results aren’t what I’d expect from 16x discs.


#10

Fuji -r is ProdiscF01.

Fuji +r is TY02… ?

How are the ProdiscF01?


#11

Problem might not be the disks anymore… I got some Verbatim with MCC and some Fuji with TYG02 and still getting those damn I/O read errors. Is this a sign of a bad drive?


#12

Upgrade the firmware to B7V9!!!

Regards,
TerminalVeloCD


#13

I did… same I/O errors I’ve been getting regardless of FW version. I’ve tried L9, P9, T9, U9, and V9… not to mention the rcp versions of the middle 3.