Problems with LTR-16102B after F/W-update

vbimport

#1

A few days ago, I got myself a new LiteOn LTR-16102B. It came with firmware version OS0F. I decided to update the drive with firmware OS0K, so I downloaded the firmware from the LiteOn-site and run the program.

That didn't go very well, because after I pressed the 'Flash'-button, I got some weird dialog box about reading back a buffer or something. So I clicked Ok, but nothing happened further. Tried it again a few times, but constantly the same strange dialog-box.

When I checked the properties of the drive, it still showed the old firmware version (OS0F), so then I definitely knew that the upgrade was not succesful.

But then the real problems started: every CD I put in the drive was recognized as an audio-CD with only one track. Doesn't matter if it's an audio-CD or a data-CD, every disc has only one audio-track on it, according to my LiteOn LTR-16102B.

Then I tried to burn an audio-CD with Nero, but I got an error message after 3%, having my first coaster in a very long time.

So I figured that maybe an entire new flash would fix the problem, and got the mtkflash-program and the bin-file for the LTR16102B. Booted in DOS and flashed the drive, everything went OK, so now the softwareversion is back to OS0B.

But still the same problem: the drive doesn't read any CD I put in it correctly. Every disc has one audio-track. Since I've had this drive for only a few days, I'm rather disturbed.

Would anyone know a solution to my problem? It would be greatly appreciated!


#2

try going back to OSOF


#3

I did, the firmware is now OS0F again. But still the problem persists…


#4

tried to flash in DOS with MTKFLASH?

I think I have one in my firmware collection.

And when upgrading through windows try to disable DMA when flashing and if that do not help, make sure that you are running the IDE drivers that is included with the OS and not IDE drivers from VIA, Intel or other chipset manufacturers.


#5

Yes, I did the flash in DOS. That went OK, no problems occurred. I used your binfile, so then the software had been set back to OS0B.

I did the flash with DMA disabled, the drive on the primary IDE-bus and with original Windows IDE-drivers. But still I had the same problem.

Then I decided to flash to version OS0F, which was the original firmware when I bought the drive. For this I used the official flash-program from the LiteOn-site.

So now the current firmware of my drive is OS0F, but I still have the same problem. Whatever CD I put in it, it’s being recognized as a disc with one audio-track of 1 kB. I’m getting a little desperate… :a