Problems with F.E.A.R. 1.2 (SecuROM 7.00.00.0149)

Hey,

I’ve recently purchased a copy of F.E.A.R. the CD edition. Until now I haven’t really bothered running it without the CD, but switching CDs is starting to piss me off.

Anyways, although I haven’t tried with earlier versions of F.E.A.R. I have confirmed that F.E.A.R. with the latest patch, 1.2, uses a newer version of SecuROM 7 than the previous versions.

[12:17:52 PM] SecuROM 7.00.00.0149 detected -> C:\Program Files\Sierra\FEAR\FEAR.exe
[12:17:53 PM] — File(s) Scan Finished [0.92s] —

To get to the point, I’d like to briefly outline what I have tried, to get F.E.A.R. running. So far, I have failed miserably.

I have tried Alcoholing the original disk completely, then used Daemon Tools to mount it. Knowing full well that SecuROM was probably going to complain about Daemon Tools, I’ve tried two different virtual disk “hiding” programs but to no avail: SR7 Stop, and Virtual-CD-Hider.

At this point I will probably just have to play with the original CD in the drive and wait for some sortof no cd crack for 1.2. However, as a legitimate owner, I’d prefer a better solution.

If anyone has had similar problems with this version of SecuROM 7 and F.E.A.R. or success stories please share them.

I just bought F.E.A.R. but haven’t tried anything yet. You say SR7 Stop and Virtual CD-Hider will not work.

I read in another post about blocking SecuROM 7 and emulation detection.
The thread is here: http://club.cdfreaks.com/showthread.php?t=126518&highlight=subinacl

Good luck hope that works

Thank you for the suggestion. I tried all the methods suggested in the thread. F.E.A.R. still ends with the emulation detected message.

I have confirmed this is not other software but only daemon tools. F.E.A.R. will run if I insert the original CD and disable Daemon Tools.

Also just as an interesting side note, this version of SecuROM has blacklisted the SysInternals Regmon (registry moniter) utility. In fact it will completely fail to run until reboot once F.E.A.R. has been run once.

If someone can find a solution to this and maybe find a way of circumventing SecuROM’s blacklisting of RegMon we might be able to find out what SecuROM is probing in the registry when its searching for blacklisted programs.

These “protections” are getting way out of hand. This “not allowing” you to use other, perfectly legitimate software is totally underhanded and I suspect illegal as well. The only people it ends up hurting are the paying customers. Every single protection out there has been broken. Guilty until proven innocent is not the way we do things!

BC

I know this was probably the case in previous versions of SecuROM, but it seems that the program DVD Region Killer is also blacklisted. Just disabling it was enough to start F.E.A.R. though. So for those experiencing trouble playing their original disc, disable DVD Region Killer first if you have it installed.

Ok, sorry for posting twice in a row. I actually manged to run RegMon (Registry Moniter) after F.E.A.R. started. I now have a log of SecuROM obviously scanning for parts of daemon tools.

From this information, I’ll probably be able to write a little program to change permissions for the right registry entries. Kind of what that script that used subinacl.exe, however it seems this time SecuROMs scan is a little more thorough.

Included bellow, for the convenience of other users, is the scan RegMon performed. Maybe someone else might be able to use this.

Registry Log.txt (63.3 KB)

This is probably completely wrong and totally below you, BUT have you tried uninstalling Alcohol and Daemon Tools, and reinstalling them by renaming them like “USBHelp” for the Name directory and changing the device names under expert setup?

Who knows, maybe we’re looking at something so easy it’s difficult. Tonight, I’m going to get cracking on it. (Not cracking, just ‘cracking’ lol) My CD-ROM is off limits so that’s why I solely rely on these types of methods.

I actually solved the problem. Most programs and scripts just seem to lock up SCSI device entries in the registry and what has also been suggested, the MountedDevices registry key.

For some reason this version of SecuROM needs you to deny it access to the entry D-Tools (Daemon Tools) in the registry as well.

Add the user Everyone to the following registry keys and add an ACE (Access Control Entry) to deny the user Everyone read access.

\HKEY_LOCAL_MACHINE\Software\D-Tools
\HKEY_LOCAL_MACHINE\Hardware\DeviceMap\SCSI\SCSI Port 4 ;this may vary depending on your daemon tools setup
\HKEY_LOCAL_MACHINE\System\MountedDevices

It would be a good idea to restore the original permissions after you play FEAR.

I am currently writing a quick application to, modify the permissions, launch FEAR and then restore them once FEAR has ended. I will provide the source code to it when I am done

Attached is the source code for an application I developed to modify the permissions for specific registry entries hopefully allowing FEAR to run from an image loaded in Daemon Tools.

I will not provide an executable until an admin okays this for a few reasons. First of all, this could potentially be used for piracy. Secondly, I’m not sure about the policies for attaching an executable.

If you have the necessary tools to compile this, do not use it for piracy. It is intended for users with the original FEAR CDs or DVD only.

Finally I will take no responsibility for problems that have occurred as a result of using the attached code, it is provided as is.

FEAR Launcher.zip (74.8 KB)

I would be really interested to know if this works. I have method of compiling so I can’t test it.

I tried to compile with the free MS VC++ 2003 Toolkit and the MS Platform SDK, but there are still headers missing, therefore compiling failed.

Yutani: The Platform SDK is not enough for this application. Unfortunately, you might have noticed, but I used MFC code. You of course know that the MFC and ATL frameworks are only included in the full versions of Microsoft Visual Studio. I am using MS Visual Studio .NET C++ 2003 the full professional edition.

Sorry for the double post. Anyways, it seems that my registry modifications will only work when you run F.E.A.R. under a limited user account. At least this is what is happening for me. It seems by running it under an Administrator account it can perform a deeper scan, or at least it is unsatisfied with being denied access to the various keys FEAR Launcher modifies.

You must still run FEAR Launcher as an administrator account, however it seems FEAR must be run with a limited user account.

The solution is to use the “Run As” feature in Windows XP, I’m not sure about the equiv in 2k. If you currently do not have a limited user account, create one.

The only other solutions to this problem are to either, develop a kernel mode driver that would hook the registry functions and hide certain blacklisted registry entries from API calls, or maybe delete the registry entries in question and restore them after FEAR finishes running.

I would appreciate it if others comment on what they think might be the best way to approach this. For the moment the limited user technique with the current registry modifications will work.

nForce: Thanks alot for this info! I’ll try. :slight_smile:

Well, that didn’t work, but I’ve got a new solution:

  1. Create a new user with restricted rights and create a password (necessary!)

  2. Open regedit.exe

  3. Rightclick on HKEY_LOCAL_MACHINE\SOFTWARE\D-Tools
    and change the permissions like this:

    In the upper part of the window, add your new user, leftclick
    him and deny his permissions completely in the lower part of the window (click the boxes to the right!).

  4. The same goes for HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 2 (scsi port number may vary)

  5. In HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices I only denied “Full access” (or similar, I’ve got a non-english XP). I’m not sure if any other combination could work, but it worked for me.

In DT, I have all emulation options activated, no SR7.Stop, Anti-Blaxx or similar is running. If you have Alcohol 120%, try these permission tricks above with it, too. I don’t have Alcohol, so I couldn’t check that.

Then I rightclicked the FEAR icon on my desktop and chose “Run as…” I typed in the new user name and its password and… voilà !

That’s the combination that worked for me, FEAR started almost instantly! Good Luck, guys! :slight_smile:

I have followed your steps but can’t get it to work (in responce to Nforce). When I “run as” another limited user, Fear says “No disc inserted. Please insert the CD/DVD.” When I just double click Fear.exe I get the security module cannot be loaded crap.

I bought this game and planned on installing over my network…well the install worked fine, but then it refused to run. I have no DVD drive on my gaming machine, just my laptop. :a

Maybe you could give idiot proof instructions?

I’m using Daemon Tools to mount the image I made using MagicIso. Maybe I didn’t rip the DVD properly? It runs fine and I can read all the files, but maybe I need to do something to emulate Securom on the ISO?

Any help would be appreciated!

[EDIT: I will give those instructions a go now yutani, thanks]

Ah well, after trying both methods above I get the same errors :confused:

I spent 35 quid on this and cant play it. thx Sierra, may everyone pirate your games until you file for chapter 11

ajpr:

You have to create an ISO with Alcohol 120%, otherwise it won’t work. The game needs the DPM data found on the real DVD in order to start properly. Daemon Tools will emulate the DPM so the copy protection thinks it’s the real DVD (or CD).

You must search in this or another forum for exact instructions how to create a proper image of F.E.A.R.

Good luck again. :slight_smile:

Thank you very much, I shall try doing that and post my results.

One of the problems with my program is that it doesnt detect which SCSI entry is your Daemon Tools virtual disk. It just uses what I have setup on my system SCSI 4. Anyways if you follow Yuntani’s advice and as I said use a limited user account it should work.