Problems with either my sony dru510ak or my pc or software

hi i’m a newbie so please dont go crazy at me if i’m posting this in the wrong place,

i’m having real problems with either my sony dru510ak or my pc or software,
trying to burn a file i converted, was useing nero recode for a long time but a few days ago i got error, saying power callibration error, so i looked on net and it said try cleaning disc and drive well i did that and nothing, so i looked again and it said try updateing nero to the new 6.3.2.5 so i did that and got even more problems, so i uninstalled nero completely and installed clonedvd and the first time it worked fine but now it wont burn at all, clonedvd does the copying prosess and then when it goes to burn to the disc it aborts with NO error message, i tried updateing my firmware useing this page but nothing seems to work, am now i can’t burn anything with my sony dru510ak, can some1 please try and help me please
,
useing winxp with sp2
amd 850
512 sdram
sony dru510ak
ricoh cd-rwmp7163a

i dont know why i’m getting this problem all of a sudden, one thing is though, my sony drive is a dru510AK but there is no firmware update for that drive on here or sony’s surrport page, on the dru510a, i dunno if that is part of the problem or not

many thanks again

chris

Please do not post the same question in so many threads (your question was posted 5 times!!!), this is considered crossposting and not allowed by our rules, please respect CD Freaks by respecting our rules.

99% of the time a power callibration error/s is result of a “bad” disc. try changing the brand of blank dvd you are using, try lowering the speed that you are writing to the dvd at, if possible.