Problems with DW1620s

vbimport

#1

Hi all,

I recently got two BenQ DW1620. One is Pro, the other is not (but I think the Pro only came with a better FW, isn’t it?).
I have the following problems (tested with TDB’s B7W9 and B7V9 firmwares):

Drive1) Will burn MCC RG03 (Verbatim -R 16X) Media actual 8X when I asked for 16X, but even worse, every DVD I try to read (CD-DVD Speed or Alcohol ISO Making) will report 4.38 GB independantly from the actual capacity of the disc. While read testing the drive in CD-DVD Speed it will give an error when it starts to read the blank sectors…
While testing reads will sometimes be 8X limited, sometimes not… even with the same disc!!

Drive2) Works flawlessly (from what I’ve seen), it burns my Verbatims in less than 6 minutes (±) but it won’t ever read a DVD-R or DVD9 at more than 8X!!!

What could be the issue?

Thanks in advance


#2

Hi poochie2: I have had a DW 1620 for awhile and just bought another because they are not making them anymore, and yes they do have a problem with some dash media, mine for instance, the older one will not burn TYG-02 media at all. I have tried all the firmwares. The newer one I just got from Zipzoomfly seems to be working great, as of now I am only using two different media codes Verb MCC004, and Yuden-000-T02-000 and they both burn excellent, the drives both always read okay. I am using B7V9 firmware.


#3

Testing some more:

Drive1) the 4.38 GB issue isn’t always there, but when it is, I get fast read speeds (but also many read failures), when not I get the same boring 8X!

Drive2) After simulating 16X burns, it won’t detect inserted blank DVD-Rs until reboot! How weird!!


#4

Make sure you eject the disc before scanning. If you dont the drive will try and read into the unburnt area and error out. If you eject and re-insert then the drive will reset the disc size reported to the correct size and should scan without problems.


#5

I tried many times, but it won’t do. Second drive got the same 4.38 GB issue with 1 dvd out of 1 tested only when I moved it to my second PC!