Problems with DW-D22A

I was having problems with Easy Media 7 and burning a DVD. Before it would complete, my computer would reboot. After checking my logs and making 3-4 DVD coasters, I decided to flash my burner. It was at BYS1. I attempted a flash to BYS2 and BYS3. I open Ltnfw and select bin. Click on Update and Update Boot Code and Start. With either bin, I get a progress bar very quickly goes to 100%. But, above the progress bar, it says Programming-Please wait.
DVD light is flashing green and steady about 1 flash per second. After an hour, it still shows Programming-Please wait. :rolleyes:
Rebooting still gives me a flashing DVD light. Have I fried this thing or is it possible to resurrect it? Any help would be appreciated.

:sad:

After reading for several hours, I’ve come to the conclusion I need to reflash using EEPROM utility and a copy of the original EEPROM. Since I, dooohhhh, didn’t know better and save a copy before flashing, I’m looking for the file. I see there is supposed to be an EEPROM request section set up. I don’t see it yet, is this still a possibility?
In the mean time, am I correct in thinking I need to reload the original EEPROM to fix my drive access LED constant flashing? And, can anyone send me an original DW-D22A EEPROM image? Would be muchly appreciated.
I have been building computers for some time but have never delved into the firmware area of the drives I’ve used. It’s new territory for me and I’m learning as quickly as possible. Thanks for this site, the Mods and Admin as well as the very knowledgable members that post to help us noobs. :clap:
Any suggestions and help getting my drive back is GREATLY appreciated. Now, off to more reading. :eek:

:cool:

Okay, I got the Lite-On package downloaded. Ran the DRU-710A firmware and converted my DW-D22A to the 710A. Rebooted. Ran EEPROM Utility and attempted to convert to 1653S. It said successful but still shows at the top as DRU-710A.
At least I’ve made some progress and got it to flash. No more blinking green LED. It will at least read a DVD/CD again. :slight_smile: Stubborn piece, can’t get it to convert to 1653S. Any hints folks???
Thanks.

:doh:

Hmmm,
Never got a single repy for assistance. :doh:
After a few more hours of reading and searching, I found the 1653 patched CSOP upgrade. I applied it and whallah…I now have a drive I.D. of DW-D23A and drive type SOHW-1653S.
So, if you are having the same or similar problem with Sony drive updates, hang in there. Send me a PM and I’ll try to help you through it. It was a long drawn out process but I managed to git 'er dun. And now I’m back to my original problem, Easy Media bouncing my computer every time I start the application. I’m working that issue which I’ll leave for a different thread. About got it cured though. At least I have an updated DVD-CD burner now!!!
:stuck_out_tongue:

@ da_ezman

Normally firmwares have the driveID belonging to that firmware, so if flashing a dru710 firmware the drive will present itself as dru710. When you flash a sohw1653 firmware your drive is called sohw1653. So far nothing new. But by using a patched firmware, you can choose what driveID you want to use, within the same drive family. I presume you used a pre-patched firmware with different driveID’s? You can make your own patched firmwares with OmniPatcher. All the info you need is in the sticky threads, in this case OmniPatcher and EEPROM-utility :clap: .

BTW, please make use of a smaller font. This way it’s like you are shouting at us :sad: .

:flower: Leo

Generally all caps is shouting, not font size. Thanks for the reply. I managed to read for many hours and found a process that worked.

:bigsmile:

@ da_ezman

You are right, caps are shouting, but this looks much better. Still wondering, in the first post you stated you flashed your drive to get rid of a rebooting problem. Did it disappear with the new firmware?

:slight_smile: Leo

Have you tried deleting the IDE channels and drive entry using Devicemanager?

HaaHaa, Ez Media is still giving me a headache. The flash was my long detour in the wrong direction trying to fix the issue. I’ve used Roxio exclusively for several year and have used it successfully on this particular computer. I just started experiencing the reboot problem.
I am running XP Pro with SP2 on a box equipped with a Celeron 2.53G proc, 1GB of DDR and 160GB hard drive. Plenty of machine to handle CD/DVD burns. I booted the machine in safe mode, turned off System Restore and ran Ewido Security Suite, Norton AV 2005 and Spy Sweeper to clean any worms, Trojans or virus that could be causing the problem. Found some stray annoyance stuff but nothing major. I deleted Ez Media v7.0 and installed v7.5. Same thing. I deleted v7.5 and installed v6, same issue. I deleted completely through Add/Remove Programs and even downloaded the Roxio remover program. I’ve gotten a copy of Nero v6.6.0.16 but am very new to it. Will have to read the entire manual before attempting a DVD movie burn. I have converted my movie files to mpg files but Nero doesn’t like that.
I have not done anything as far as IDE channels. Are you suggesting I delete the drive in Device Manager and bouncing to let XP reinstall? I’m willing to try anything. This is the first and only box I’ve had a problem with Roxio software. If Nero is better, I’m game for a swap. Just have to get familiar with it.
Thanks again for the responses.

:slight_smile:

I deleted DVD drive and both IDE channels. I also reflashed unit to DW-D23A. Rebooted and about to attempt Ez Media v7.5 again on this box. Keep your fingers crossed. I’ll post my results as soon as I finish the reload and attempt a burn.

:rolleyes:

This is just crazy and for sure isn’t related to a drive issue. Ez Media still causes system reboot when I attempt to burn a CD or DVD. I looked in my logs and see a fax failed to initialize statement each time it bounced. I deleted my fax machine and reinstalled. Reloading Ez Media v7.5 one more time. For the curious, I did burn a data CD using Nero. Went fine. Chalk up another glitch to Roxio. I’m gonna press on till I figure this one out or figure out how to get around in Nero a little better. :slight_smile:

:stuck_out_tongue:

Can finally get through a complete DVD burn but with Ez Media v7.0. I flashed my drive back to DW-D22A with BYS3. It was burning at what appears to be 1x since it takes around an hour to burn a 4.6G video DVD. I even swapped my drive to a new NEC 3540 with factory flash. Still takes an hour or so to burn a video DVD. :confused:
Steps to get rid of original problem with bouncing computer:
Deleted Ez Media 7.5. Reloaded v7.0.
Deleted HP all-in-one fax machine and reinstalled.
Cleared CMOS and reset everything.
Under Device Manager, deleted optical drive and both IDE channels and let Windows XP reinstall after bounce.
All of these may have played a part in clearing my problem. Flashing DVD burner made no difference. Just wish I could get a faster video DVD burn.
:rolleyes:

Maybe a stupid question, but did you check your dma? Current dma should be UDMA2 (could be 4). If even a new drive gives no improvement, there could be something wrong with your dma.

:confused: Leo

DMA should be UDMA4

@da_ezman, don’t take me wrong but most of us ARE helpful. :stuck_out_tongue:
Nevertheless we like our members to use SEARCH button and read sticky threads before asking question that have been answered many times.

And there is no magic in your findings. C0deguys have all the Lite-On/Sony tools (and firmwares) you will ever need. (see attachment.) :slight_smile:

BTW, why not supply more adekvat info about your setup/system and the media you are using in next post. (Nero CD/DVD Speed and DVDIdentifier might be helpful.)
And please stop using “Comic Sans MS” fonts because they are no fun at all. :wink:


Didn’t know there was a required format here as far as font and size. That would explain why I didn’t get any quick responses. :slight_smile:
Although, I didn’t see that addressed in the forum rules and the “Read Before Posting” info.

Don’t take my reply wrong. I do appreciate the site, Mods/Admins and the heplful members here. A lot of information available too.
MANY thanks for the help and guidance for a noob. New to firmware and internals of optical drives. NOT a noob to electronics, computer hardware or forum etiquette. I’m learning as fast as I can and hope to return the favor to the forum.
Thanks again!!!
Oh, and I will check my DMA settings when I get home this evening. Thanks too for that hint.
:wink:

Device Manager says primary IDE is showing Device 0 at “Ultra DMA mode 5” and Device 1 at “Ultra DMA mode 2”. Secondary IDE, where my optical drives reside, shows Device 0 as “Multi-Word DMA mode 2” and Device 1 is “Not Applicable” probably since it’s a DVDRom drive.
I have my hard drive on primary IDE and both optical drives on secondary IDE. Anything I need to change there?

Sure you do! You have to change your dma. SecondaryIDE device 0 (your writer) should be ULTRA DMA 4 and device 1 ULTRA DMA 2 (I suppose, even my cd-rom drive is). I have no XP, and I can simply switch dma on and off, so I’m not familiar with the procedures how to do that in XP. But it’s written all over this forum many times. Success!

:rolleyes: Leo

I deleted both optical drives and Secondary IDE Channel. Replaced IDE cable and made sure it was an 80 pin. Bounced computer and still getting DMAs as shown.


I’m running an ECS PT800CE-A M/B w/1GB of PC3200 DDR. I went to ECS site and D/L the latest BIOS and VIA driver pack. Included in the pack was the IDE Controller driver. Also went into regedit and deleted the ID tags as suggested.
Deleted drives and Secondary Channel and bounced. Same results as above. Any suggestions on getting the secondary to UDMA4? Oh, and I even tried in the BIOS to set the mode to 4 manually. No help. UDMA capability is active in the BIOS also.
Thanks for any help and suggestions. Will keep searching posts. I’m not giving up.