Problems with Acer CDRW

vbimport

#1

I need some help. I had a ACER 2010A running WinXP on a Athlon 1400 computer, Asus MB, 512 MB RAM, two HD in IDE1 (to get advantage of ATA100), and CDRW as master and Artec DVD in IDE2. The system (although CDRW and DVD share the IDE channel) have worked fine for a year.

But two months ago CDRW started to spoil CDs with buffer underruns. The CDRW internal buffers swings from 98% to 7%, stops the recorder and then fills the buffers and start again. CPU usage is very high (>90%). It happens with every CD brand. CloneCD also fails when recording. If I select slower speeds, buffer remains stable. NeroInfo tool says HD are DMA mode 5, DVD is DMA mode 2 and CDRW is PIO4 (Acer says this is the rigth mode for its recorders). I have tried to install drivers, uninstall last applications, remove every serial device, clean register…It is driving me mad, because it worked three months ago.

Has anybody any suggestion? Clean the hardware? Format the HD?

Thanks


#2

PIO mode 4 is NOT the correct mode for a CD-RW drive since it’s imply too slow and the cause of your problems. Set it to UDMA mode 2 if your drive supports it.


#3

Yes, but it is the fastes mode recorder supports (Acer confirms it on the web page). But the most strange thing is that the system worked fine, and recorded a lot of CDs at maximum speed (20x)


#4

I’m 100% sure that your writer needs to be running in DMA mode, and probably MultiWord DMA mode 2 (since it does not support UDMA33). PIO mode 4 is simply not fast enough to supply your writer with enough data and the problems you described are exactly what you would expect when DMA is not enabled. Please try the following:

Go to: Start, Control Panel, System, Hardware, Device Manager, IDE ATA/ATAPI Controllers and select the IDE chain your drive is on. When you see its properties go to Advanced Settings and set your drive to DMA mode. Now reboot and check if DMA is enabled. If not then you can try to delete the IDE channel your drive is on in the Device Manager. When you reboot Windows XP will detect your drive again and (hopefully) enable DMA for it.

It’s a common problem that Windows XP will sometimes set a MultiWord DMA mode drive, which I think your Acer is, back to PIO mode 4 resulting in the problems you’re experiencing. Please report back!


#5

Now I am at home. I confess I tried to change in BIOS the DMA mode for recorder (is always detected as PIO4, as acer support states), and recorder was not recognized. Now I have tried it again, with no success, and then I have deleted, from control panel/system/hardware the secondary ide channel and the VIA bus master. Reboot, WinXP detected new hardware and reboot again and voila! Now Word DMA Mode 2 appears in the recorder and works fine again.

Thank yuo very mucha and sorry for the initial doubt. I hope this helps someone else.

Thank you again. I owe you a coffee

Rafa from Spain