Problems with 52327S firmware compare

vbimport

#1

Mine is the first hardware revision. I have already flashed my drive to QS0E a while ago but when I was running a speedtest today it wouldn’t go above ~24x no matter what. However, usign K-Probe’s C1/C2 testing it reads up to 49x so shouldn’t be any issues with the disc. Average C1 was 4.8 and C2 was 0 (go taiyo yuden :P) But I got worried about the 24x on the speed test so I downloaded the newest firmware from Lite-On, extracted the QS0E from the dual pack and tried a compare using the “Firmware Flashing Tool” and got the result offset 0x0102 is different. I backuped my current firmware and did a compare on that, perfect match! Then I tried re-flashing multiple times, with and without update boot code checked, same problem. Any ideas with what may be wrong with my drive?


#2

The official flash tool is not flashing the bootcode area and this is why the compare fails. It is not always necessary to flash this area and you have nothing to worry about. Your speed test was probably slow because you used a disc that the drive chooses to read back at 24x for best results. Maybe DMA isn’t enabled. There’s probably nothing wrong with your drive.


#3

I didn’t use the offical flash too to re-flash, I used “Firmware Flashing Tool” as the program calls itself and I tried with and without flashing the boot code area. Even though the speed test couldn’t exceed 24x, the K-Probe utility was doing 49x so it isn’t the drive limiting it at 24x. And why would a drive choose to read back a taiyo yuden with c1 avg of 4.8 at 24x? :stuck_out_tongue:


#4

The media wouldn’t happen to be CD-RW would it?


#5

The media in question wouldn’t happen to be CD-RW would it?


#6

@SSSeth, double posting is not allowed… :stuck_out_tongue:


#7

LOL! I thought that was only for cross-posting, not double-posting? :wink:


#8

Lol. Yeah, its CD-R. And its not that the drive can’t read it at faster than 24x because K-Probe does read it at higher speeds when doing the C1/C2 Error test. BUT, the benchmark in K-Probe also gets stuck at 24x ><

The attached images arn’t Taiyo Yuden though, I’ll change them later if that helps…gotta go to class now :smiley:




#9

Is it only happening with TY media?


#10

Hmm interesting… Well, the one posted above isn’t TY media but I fixed it now :smiley: I moved it from primary slave to secondary slave and ran the tests again and it worked! So I moved it back to primary slave and it is still working boggle No idea what the problem was but it is working now :smiley: Thanks for the help :smiley: