Problems using utilities with my LDW-811s

vbimport

#1

EDIT: If you found this via a search, the problem was solved by removing CDRWIN5 from my system. This software was causing a CD image simulation device to reappear constantly in my device manager, despite being removed manually. When present, this device appeared to interfere with the ability of several of the lite-on tools to properly recognize my drive(s).

I’ve spent 2 days searching on this, found lots of threads kind of touching on this issue, but nothing that really seemed to fit my situation, so I’m posting in hopes someone can suggest what I need to look at.

I have a LDW-811s, firmware HS0K, on a p4 running Win 2k.

I can’t seem to force the booktype setting on my dvd+rw to dvd-rom. Also, when I run the booktype utility (I’m using 1.0.4) or kprobe, under the drive selection tab, I never see the drive brand/model, only the bus-id’s…e.g. 2-0-0-0, but no “Lite-On DVDRW LDW-811s HS0K”. Also, the firmware updater for HS0P fails to recognize my drive (“No matched drive detected! !”).

Nero, and other burning software, and windows all see the drive, and model correctly. I seem to have up to date IDE drivers. I do seem to have a system ASPI and Nero ASPI, and I had some suspicion from my searches that this could be at issue, but I couldn’t quite gather in what way, or what I should/would need to do about it.

I don’t know what else to look at - I’m happy to post any other info that’s important that I overlooked here, or can gather.

Thanks for any ideas, it’s kind of frustrating. I have some devices in the house that don’t like DVD+RW very much but that I have verified will work with booktype-set disks, so this is a problem for me.


#2

Could be ASPI related.

Check you ASPI layer with aspichk.
The layer should look something like this if it’s working right:

If something doesn’t look like the above, fix (force) your ASPI layer to 4.60 with this. Make a backup copy first incase you want to go back.


#3

Hi Ssseth, thanks for the response.

All 4 ASPI version numbers are the same according to the tool you linked, 4.60 (1021). The graphic in your post indicates 1017, so I wondered if this might be the problem, but the documentation included with the frcasp17.zip indicates that it would install 1021 also.


#4

I had the same problem. It turned out to be the IDE drivers I used. Try the MS drivers (if you are not already using them)


#5

Androlight, thanks for the reply.

After reading that I did my best to make sure my IDE drivers are up to date, and also am using the MS supplied drivers.

My MB is a ASUS p4t533-c which uses a 82801 BA ICH2 intel IDE controller. I am using the MS provided drivers, version 5.0.2195.6717 dated 6/19/2003.

This is the most up to date driver I can find, and behavior is the same.

I neglected to mention that at least once since I’ve owned this drive (maybe 3 months? Not positive) things have worked properly, as I was able to upgrade from the shipped firmware to HS0K.

Thanks everyone for reading and contributing ideas.


#6

Did it happen right after you upgraded the firmware?

Is your drive configured as master on secondary IDE (no slave drive present)?


#7

I am not positive if it happened immediately after upgrading. I am pretty sure the answer is “no”, but I can’t authoritatively say so. I don’t run the tools very often, and most of my blanks at the moment are -R, so it’s possible that it did happen right away and I just didnt notice until recently. I don’t believe that is the case.

The drive is not the only drive on its chain. Should it be? It is master on secondary IDE with another drive present (another Lite-On, a CD-RW drive).


#8

It could be a bad flash. Not really sure.

Liteon 411 and 811 prefers to be single drive on the IDE channel. Nero could’nt write the lead-in when I had an old cyberdrive installed on the same cable.

Can you try the drive in another PC? This would help a lot in troubleshooting.

BTW, What version of Kprobe are u using?


#9

kprobe version is 1.1.28

I dont have another PC to test in, unfortunately. If I dont make progress, I can cast about my friends to see if someone has one I can borrow for testing.

I will try putting the drive on its own chain (i.e. removing the other drive) later this evening when I can afford some downtime.

fwiw, everything except the line-on tools seems to work fine. nero burns good discs, dvdinfopro accesses the drive fine. sending a “iniquiry” command under kprobe, and dvdinfopro returns the full info, including make, model and firmware.


#10

It seems I read somewhere that dvd+rw can only be bookset the very FIRST time it is used.


#11

generic user, thanks for your reply.

From what I have seen, CD+R can only be set once, but CD+RW can be reset. But it seems to require a full-erase, at least in some cases. I have had some luck with this on this drive in the past.

My bigger concern at this point now is why the drive doesn’t get recognized by make and model and firmware by any of the lite-on tools. I still owe androlight a report on trying his last suggestion (of putting the drive on its own IDE channel).

Thanks again to everyone who has read, pondered, and/or replied.


#12

I had the same issue when I upgraded to HS0K, except the burner was not detected in bios and windows halted 1/2 way thru
loading.

To fix, i did the following.

Disconnect the power, and IDE cable.
Boot windows.
Shutdown.
Reconnect drive power & IDE.

Start, get into bios, ensure that it’s on autodetect/cdrom for the right port and restart the machine.

I still have no idea why that worked.


#13

Originally posted by genericuser
It seems I read somewhere that dvd+rw can only be bookset the very FIRST time it is used.

I´m “testing” firmware FS0J [411] and bitsetting tool right now…

Done my 3rd boktype change on same Ricoh. DVD+RW>DVD-ROM>DVD+RW>DVD-ROM>DVD+RW>DVD-ROM.

And it still shows up as “DVD-ROM” in DVDInfoPro… :smiley:

So, don´t worry :cool:


#14

debro and pinto2, thanks for your replies.

debro I will add your sequence to my list of things to try tonight. I am still doing some workday work and cant yet shut down to do these tests


#15

When you say ‘the newest version’ of IDE drivers. That is not what you are supposed to try. Try the default Windows IDE drivers. The date (with WinXP) should be 2001 with Wink2K I’m assuming it should be 1999.


#16

ssseth,

thanks for the clarification on that. I will also add that to my list of things to try tonight.

I definitely would not have surmised from the posts I read that I should try downgrading. Thanks!


#17

I had also a problem with K-Probe not recognizing my 811. The problem was Adaptec ASPI. What I did was to replace
the Adaptec ASPI file WNASPI32.DLL in the sytem folder with Ahead WNASPI32.DLL which is smaller and resides in the Nero folder. It worked perfectly for me.

Good luck!


#18

I wanted to thank everyone for their suggestions and input and sheepishly apologize for taking a few days to follow through on all of them. I had some long batch computing jobs I had to leave running over a few evenings and couldn’t afford to shut down until just now.

I think I’ve tried everyone’s suggestions, but still no luck. The drive seems to behave normally and interact with every other program than the lite-on utilities just fine.

Using kprobe, the program senses that a drive is there, it just doesnt report the “name” of the drive (make, model, firmware ID). I can query the drive and get a response. It even seems to run, e.g., the disk analysis just fine.

Cataloging responses to people’s suggestions:

I tried making it the only drive on it’s IDE chain: no change
I tried the “boot without the drive, then reboot with the drvie”: no change
All my ASPI drivers are the same version, however I do have a nero ASPI in addition to my system ASPI. I don’t know what to make of that.
I tried the suggestion of copying the ahead ASPI over my system ASPI - no change. HOWEVER, I did also notice that my ahead ASPI was larger, and not smaller than my system ASPI, which contradicts what jurass said, so maybe I have the wrong ahead ASPI drivers for this to work properly. I don’t know.
I tried downgrading my IDE drivers as far as I could - unfortunately, the oldest IDE drivers I could find were not from 1999-2001, but mid 2003. I think may or june. Possibly a service pack has overwritten the shipped IDE drivers.

attached is a picture of what I see when I run kprobe.

Thanks for the inputs folks, I appreciate the suggestions. If you have any further, I will appreciate them, too.



#19

Have you tried updating/changing the firmware using a firmware tool found in my tool guide?
Check the tools guide for link to download LtnFW.
Reload HS0K, you will need a .bin copy for it to work with LtnFW, find a copy here. Hopefully that will fix it.

Regarding setting the booktype, make sure you are doing a full erase on the DVD+RW disc before trying to set the booktype (you can use DVDInfoPro for that).


#20

Ssseth,

wow you are on top of things here and quick to offer help. I very much appreciate it.

WRT bitsetting, I discovered the need to do a full erase just last night, and that seems to work.

I will try reflashing with ltnfw.exe. I did download a .bin of HS0K and did a compare and got an “identical” result. Do you think it is still worth a try to reflash? Can’t hurt I guess. ltnfw.exe displays the same behavior of showing only a bus id and drive letter, not the full drive description. I don’t know if this reveals any extra useful information.

Since there are tools to force a flash, I guess I don’t really have a problem. I appear to be able to bitset, and I can force a reflash using 3rd party tools. My main concern now, I suppose, is that this is indicating a problem that will come back to bite me in the future. Should I just let this go and not worry about it?