Problems installing Leopard

Hi,

I’m new to Macs, but I’m usually pretty good with computers in general. I was recently given an Imac and needless to say, I was a bit lost at first but i caught on pretty quick. I recently have been been trying to fix a few things with my Imac. My Pioneer dvr-106d had been giving me problems reading and successfully burning discs. I tried flashing my drive and changing it from firmware revision a612 to firmware revision 1.08 and no such luck. I solved that problem by simply cleaning the drive’s laser. After several wasted blank discs and about a week of lack of sleep, I managed to burn a mountable copy of leopard 10.5.6 to a single layer disc as seen in several techniques online. The installer loads and even gets as far as checking the disc for consistency, but once the installation actually begins it fails and i have no clue as to why. I tried using DVRFlashX to flash my drive back to the A612 firmware revision to see if that made a difference but i got nothing. I’ve seend plenty of posts where people with the same exact iMac and specs have installed successfully. Could anyone tell me exactly what all the system requirements are for installing it successfully and what could be lacking from my attempts? Here are the specs on my Mac and my drive as of right now:

Machine Name: iMac
Machine Model: PowerMac6,3
CPU Type: PowerPC G4 (3.3)
Number Of CPUs: 1
CPU Speed: 1.25 GHz
L2 Cache (per CPU): 256 KB
Memory: 768 MB
Bus Speed: 167 MHz
Boot ROM Version: 4.7.8f1

and:

Firmware Revision: A612
Interconnect: ATAPI
Burn Support: Yes (Vendor Supported)
Profile Path: /Library/DiscRecording/DeviceProfiles/PatchBurn-pioneerdvdrwdvr106d.drprofile
Cache: 2000 KB
Reads DVD: Yes
CD-Write: -R, -RW
DVD-Write: -R, -RW, +R, +RW
Burn Underrun Protection CD: Yes
Burn Underrun Protection DVD: Yes
Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
Media: No

Here are my graphics specs also in case that matters:

Chipset Model: GeForce FX 5200
Type: Display
Bus: AGP
VRAM (Total): 64 MB
Vendor: nVIDIA (0x10de)
Device ID: 0x0329
Revision ID: 0x00a2
ROM Revision: 2079

by the way I am currently running Tiger 10.4.1 trying to go to Leopard 10.5.6. I was gunna try a clean install but whats the point if the installer is failing now. I don’t wanna be left without an installed operating system.
P.S. when the installer ails it says the installer wasn’t able to find what it needed to install. Check internet connection or contact the support from Apple basically. Any help would be great thx guys.

Did you verify your burn of 10.5, to make sure there were no errors?

Yes, i did. At first, before cleaning my laser, I was having several Medium errors while trying to use any burning app and even disk utility. The discs never made it through the verifications after writing. That problem ceased after cleaning the laser. Once I had a working copy of leopard, verified and all, i ran the installer and allowed the installer to check for consistencies in the disk and that completed 100%, but directly after when it went to the actual installation portion, it immediate failed. i just tried to verify my HD in disk utility and got this:

Volume Header needs minor repaire
The volume Macintosh HD needs to be repaired.

Error: The underlying task reported failure on exit

1 HFS volume checked
Volume needs repair

I found a thread that stated that reinstalling my current OS (tiger) would fix that problem, but i have tiger on a burned disc also and that one doesn’t seem to wanna boot. Idk, i may need to re-burn that disc also. but could that error be the problem?

Usually the Mac installers are bomb-proof and report any things that need to be fixed before a successful install can be done.

Try running the disk cleanup utilities of Onyx (free):

… and try again.

Update/upgrade is the proper way in this case, no new install.

@imkidd57 So, I tried using onyx and pretty much ran everything that came with the program. I went and tried to run the install disc again. I let it check the disc for inconsistencies and once again, when it got to the installation portion, it immediately failed and gave me the same message. It basically tells me that the installer couldn’t find what it needed to install, to check my internet settings, and/or call support for further help pretty much.
@chef i’ve heard that once already, but how exactly can I? i’ve tried whatever i can think of to my limited knowledge. I’ve searched through page after page, forum after forum with no working solution thus far.

Just curious, where did you get the OS from?

the friend that gave me the iMac made a backup of copy of the retail version of Leopard he had purchased to sweeten the deal for me because i only have experience with using Leopard so that’s the only OS I felt comfortable using. He told me it should be an easy install, but I’ve been struggling to install since. I tried using Onyx as previously suggested and ran pretty much every operation within the program possible, tried to install, and still no such luck.

Then please use the original disc to install the OS. Additionally, check Apple support website if your system meets the requirements of that OS version.

Michael