Problems flashing hp dvd1040i with lite on dvdrw lh-20a1h firmware

vbimport

#1

i used both the flash and eeprom utility to back up my firmware and eeprom to flash my hp dvd1040i drive with lite on dvdrw lh-20a1h LL0D.
i am able to flash the firmware to the drive and it seems to go ok i can see the MID in imgburn fine and all but after doing it for some reason it won’t burn dvd-r anymore unless i flash it back to the hp firmware!:sad:
i can dump iso files from disk and burn to my dvd+rw(don’t have any dvd+r to test or dvd-/+r dl disk)
in IMGburn it sits at “writing leadin…” forever and keeps retrying to do that.
any one know what could cause this problem?:confused:
if anyone is interested they are TDK dvd-r with cmc,mag,am3 MID and some cheap JVC media i tried to burn and it doesn’t make coasters of them it just doesn’t burn anything at all dvd-r wise.:frowning:


#2

I can test the hp firmware in my 20A1H to see if I have the same problem, just send it to me.


#3

here is hp’s fimware
http://www.esnips.com/doc/67e642ec-0ab8-4a15-8010-ae0cbe5936cc/MH21
but it works fine with dvd-r but the drivers for it haven’t been updated by hp since 2007 so i wanted to have it up to date as possible.
hence why i wanted to flash it with the real lite on firmware.


#4

OK I downloaded the firmware, I flashed my 20A1H to Hp 1040 firmware. I was able to burn DVD-R using the Nero CDDVD Speed. I’m going to try Imgburn.

Have you tried to use LL0C? I’ve read somewhere that LL0D was buggy.




#5

[QUOTE=juancdg;2190337]
Have you tried to use LL0C? I’ve read somewhere that LL0D was buggy.[/QUOTE]

yes i have tried both LL0C and LL0D both versions of firmware can burn my +rw but not my -r
after trying a second time to burn dvd-r without closing IMGburn i get this i/o error.

i have heard it could be my ide cables but it burns other media just not dvd-r so i don’t think that’s the case here.
i was able to backup up a dvd-r movie burn it to the +rw disk and play it on my dvd player so it reads the dvd-r fine as well.


#6

seems it might be best just to get a new burner (this time one that isn’t rebranded cuz i just tried cd-r and it won’t burn them either.
i’ll just have to be content with hp’s outdated not updated firmware till then thanks anyway for all your help.


#7

That’s because its a 20A4H hardware, and this one model code covers two different writers. Fortunately, there’s firmware available for both. Just use whichever one works better–the “A” model or the “S” model.
The firmware is located here:
http://club.cdfreaks.com/f44/liteon-dh20a4p-h-fast-burn-enhanced-overspeed-enhanced-oht-firmware-231875/#post1931131
Edit: and yes, this firmware works on HP dvd 1040e, dvd1040e, dvd 1040i, dvd1040i, and 20A1H