Problems copying a non-original movie

Hi there. I’m having a bit of a problem here. I was lent a pre-backed-up video and I was trying to copy it. Now - since it was pre-backed-up ripping should not be an issue right? I tried Pinnacle’s Instant Copy to copy the movie… All seemed well. It even played fine on my DVD Rom in my computer… But it refuses to play on my stand alone unit - yet the movie that was lent to me works fine.

I’ve even tried using Nero with no luck

My burner is an I/O Magic 4x4x12 CD±RW with the latest firmware.

The media I was using is TDK DVD-R for Video applications.

The original Media - I Have NOooooOoo clue. No identification marks from what I can see.

My stand alone player is an APEX AD-1200 (the version with the Mediatek Video Processor - as I said it played the original backed up video fine - just not my copies)

BTW not sure if this makes a difference or not. But i’ve always set the burn at the lowest speed.

Any suggestion or help would be appreciated. Thanks.

It is against the law to backup any copyrighted movie unless you own the original.
It is also illegal to make more then one backup copy even if you do own the original.

Congrats, you are breaking two laws at once.