Problems Connecting PC to TV using DVI to HDMI

[qanda]This thread is about the Philips 42. Click here to see full specs[/qanda]I am trying to connect my PC(using Geforce FX5600 graphic adapter) to Philips PFL9703D (Full HD) using DVI to HDMI cable.

when I connect the default resolution is 1024x768 and quality is good, but when I try to change the resolution to 1920x1080, the image becomes unsharp, it is even hard to understand what is on screen.

what could be the problem?

This gfxcard is outdated for such a res.

Hi, I am afraid people jump too fast to conclusions when they see an older, but still amazing Graphics Card like the FX5600.

I have a Philips 47’’ PFL7403/78 and an I’m using an FX5600 connected to it at Full HD resolution 1920x1080 (1080p) and with much better quality than through the VGA interface (which, by the way with this Philips can only run at most 1376 x 720 anyway!).

But there’s a catch! You won’t get good results just by plugging and playing… Before we resort to praying let me show you what happened when I hooked everything up…

First I switched from VGA to DVI-HDMI because, as I said, VGA mode in my Philips do not go to FULL HD! Stupidity of design? Yes, of course.

When I hooked the DVI cable to the TV it switched to 1280 x 1024 with crystal-clear Image! The TV, just after adjusting to the setting displayed the resolution it detected as 720p… Which is not FULL HD… From now on we need to take care: We want to avoid any Interlaced resolution or else everything will blink!

Then I went to NVidia Control Panel and changed the resolution to 1920 x 1080… The TV blinked and then adjusted and displayed that I it was running at 1080i (INTERLACED!!!), and everything was very crap.

I went to Nvidia Control Panel again and found at the bottom options a place to change the output format to 1080p… This was available because the box “Treat as HDTV” was checked. The TV then blinked and adjusted and displayed the info it was running at 1080p… The image was still bad, just without flickering as it was not interlaced anymore, but very, very, very bad compared to the 1280 x 1024 resolution it displayed when I first hooked everything.

I spent a few hours tinkering with everything… I’ll make it short for you!!!

My Philips TV has an option under the menu item FUNCTION called MODE… There are two options: PC and HD… HD is for when it is connected to a HD source like a upscalling DVD, a blur-ray player, etc… It gives CRAP image when connected to a PC… The PC mode is just for that: it giver crystal clear, perfect image when connected to a PC!

Find this option in you TV menu and chose the PC mode.

Also, uncheck the Treat monitor as HDTV in the nvidia control panel as it may interfere with the MODE menu being shown… I am almost sure that it didn’t show and only after switching to a 720p resolution it appeared… But it may be just me going nuts.

To summarize: MAKE sure you put your TV in PC mode (your manual surely will help), then make sure your nvidia is configured to output 1080p (1920 x 1080). You’ll get amazing quality.