Problems after firmware upgrade LTR-40125S

vbimport

#1

Hi I have the LTR-40125S and I just flashed it to firmware version R40ZS0K. I run WinXP and the drive is S model and I did get the latest and correct firmware. However I just read on the reply about having DMA mode off which I did not have during the flash. Is this a prob and should I redo it?

Now when I run the Nero CD speed utility, the Scandisk feature seems to crash all the time. Also I get the following msg when I try the File test;

Starting file test
Files: -
Directories: -
Size: -
Errors: 0
Speed: (-)
File test completed

The surface scan works when the program doesn't crash. I never had the problem b4 the firmware upgrade. Has this happened to anyone? :eek:


#2

First of all double check that u got the right firmware for your drive, espeically the s and w model part. Second, does the CDRW still read cd fine, burn cds, etc etc.? Also list out other info, like OS, ASPI version, etc., and make sure you flashed your firmware with DMA mode off for your drive.

Please list your results
DFourthHorseman


#3

Hi I have the LTR-40125S and I just flashed it to firmware version R40ZS0K.

I’ve had program crashes (win2000) with CDSpeed since updating to 5.5.9.0. Usually a reboot is needed to get it working again. But it’s only with the ScanDisc function. The “Quality Check” feature does a better job of reading errors anyway.


#4

Should I redo the flash with dma off? Or have I done some kind of perm damage to the drive by flashing it with DMA enabled?


#5

I seriously doubt you’ve done any damage to the drive. You can always reflash the drive with mtkflash and the right .bin file and with DMA off if you just want to be sure it’s done right ( and maybe for some peace of mind). :wink:


#6

@SaSH,

You don’t need to redo the flash if your drive is recognised correctly with the new firmware. While DMA is supposed to be turned off while flashing the drive, it doesn’t seem to materially affect the result.

I’ve flashed a Liteon (accidentally :stuck_out_tongue: ) without DMA off in Windows. It works!

However, I’m rather queasy about repeating the experiment :smiley:


#7

Flashing with DMA on should work just nice.

But in some cases with crappy IDE drivers it may be required to switch off DMA.

So as long as you did not get any problems there is nothing to worry about.


#8

Ok, where does it say in http://www.liteonit.com.tw/english-load-how.htm that DMA must be off?


#9

Where at that page is it mentioned that DMA must be off?


#10

So, why does SaSH say that DMA must be off?


#11

It’s no required to have it switched off, but it may be wise to disable it to avoid any potential problems.

In most cases it will still work nice with DMA enabled…


#12

I can say that I flashed my 40125W to the latest firmware w/in WinXP w/DMA still enabled, all went well too… :slight_smile: