Problems after Firmware Install on Philips 1640p! PLEASE HELP!

Hi Folks,

my Nero had problems after a Windows Reinstall to Write DVds with my Philips 1640p and because of that i tried to install the newest firmware ver.3.7 !
At 25 % of the Firmwaring Update my Windows Crashed and after Restart my System just Recognises the Drive as

ATAPI DVD DL DW1600 Current firmware : FS02

When i try to Flash it again, under Windows, it just says, that the drive is not supported.

I dont know what to do next.
When i Run DISCInfo it shows me:

ATAPI DVD DL DW1600 Current firmware : FS02

Nothing Else!

Did i broke my drive=? =

Please, i hope that you can help me! Im going slighly mad about this problem!
Thank you so much for every answer !

Hi,

it seems that your drive is in a sort of safe mode. Have a look at the thread about BQFlasher in the Benq/Philips section. Maybe you can reflash your drive using that.

Michael

Hi :slight_smile:
Welcome to the forum bilybas. :clap:
As long as drive still functions mechanically e.g. tray opens/shuts. drive spins up etc. Then the drive may be recoverable. No guarantees’ though.
As mciahel suggests BQFlasher is worth a try. Also in this case flash in safe mode. Take a look [U][B]here[/B][/U].