Problem with UDMA2 @ PX-708A

vbimport

#1

I try to explain it point by point because of my *$&%$% english :>

my system:

P4 2.8 Ghz
Asus P4P800
Corsair TWINX1024 PC3200LL
MSI Geforce FX5900
PX - 708A, IDE1: Master, (Jumper is set to Master), 40 Pin Cable
2x 120GB Seagate S ATA ST3120026AS @ RAID 0 (ICH5R Onboard Controller)

Nero 6.3.1.10
PX Firmware 1.07
Intel® Chipset Software Installation Utility V5.02.100
No IAA

I can only set UDMA2 for my Plextor 708A via Plextools Professional v. 2.15.
After enabling it from Pio Mode to UDMA2 Mode, my system crashes and doesn’t react to anything, the only thing i can do is to eject the cd or wait 5 minutes and wait that windows will change the Transfer Mode from UDMA2 to Pio Mode automatically.

If Im using Pio Mode the CPU Usage will rise up to 50% and more while im burning a normal CDR, and it will take up to 10 minutes @40x to burn a normal Data 700MB CD, (DVD @ 4x around 40 minutes).
The Plextools Read and Write Transfer Rate Test says that my recorder has only an average of 20x (reading&writing)

thx 4 ur help
(and of course i read all the dma threads and faqs here o_O)
greetz from germany :>


#2

check your motherboard chipset drivers…if you have a nforce chipset you may need to use modified drivers for it…it’s in the FAQ…if you’re using INTEL APPLICATION ACCELERATOR uninstall it and use the microsoft drivers…to enable DMA take a look at this guide on how to enable DMA:

http://www.cdrlabs.com/phpBB/viewtopic.php?t=7625

upgrade your NERO BURN to the latest version or use a older version like 5.5.10.42. hope this can help you out.


#3

i can enable udma2 mode the way u said but there are still the problems that nothing reacts after the reboot, when i dont eject the drive. ive no iaa installed and the latest nero version didnt work for me :confused:


#4

Since rabble’s motherboard is ASUS P4P800 with Intel 865PE/ICH5R chipset, nVidia chipset & IDE drivers are not applicable. Intel IAA RAID Edition (specifically the IASTOR.SYS driver) is needed to support the RAID 0 array with two SATA hard discs. Uninstalling IAA RAID Edition is NOT the proper thing to do in this case!

The older IAA 2.3 does not support the 865E/ICH5R chipset and will not install anyway.

Rabble: try the following in the BIOS setup of your P4P800:

  1. Under “IDE Configuration”, set “Enhanced Mode Support On” to “S-ATA”. “Configure S-ATA as RAID” should already be “Yes”, and “Serial-ATA BOOTROM” should already be “Enabled”. This config allows the P-ATA primary and secondary channels to assume legacy resources (IRQ 14,15, etc.) for maximum compatibility.

  2. Under “Advanced”->“Chipset”, if “Performance Acceleration Mode” is set to “Enabled”, try changing to “Disabled”.

By the way, is your OS WinXP or Win2000? Either way, it is important to have the latest Service Pack installed: SP1 for WinXP, SP4 for Win2000.

Can you see the PX-708A within Device Manager?

Here are some more suggestions if you haven’t already done them:

  1. Download and install the latest release of Intel Application Accelerator RAID Edition from the Intel website. Here’s a link:

http://downloadfinder.intel.com/scripts-df/filter_results.asp?strOSs=44&strTypes=DRV%2CARC%2CUTL&ProductID=1049&OSFullName=Windows*+XP+Professional&submit=Go!

For the P4P800 I recommend IAA RAID Edition 3.5.3.

  1. Download and install the latest BIOS for your ASUS P4P800. The latest BIOS contains an updated Intel RAID Option ROM for your RAID array.

#5

After i installed the IAA RAID Edition 3.5.3 and disabling the PAM, every program that is related to the dvd device is still not responding. ( under UDMA2 Mode)

Im using WinXP with SP1 and several hotfixes, the latest biosupdate v 1016 and ofcourse
i see the PX - 708A under the device manager.

can u explain where i can find the new intel raid option which you said above.

edit: when i insert the disc once again windows will set it to PIO Mode automatically


#6

The option to set Intel RAID mode is under “Main”->“IDE Configuration” in the BIOS setup of P4P800. Since you are already running in RAID 0 I don’t think you need to worry about this setting. It should be correct already.

Perhaps you should check the IDE cable used for your PX-708A. I recommend using a 80-wire IDE cable for improved signal integrity, as some 40-wire cables can have marginal/poor signal integrity at the UDMA mode 2 (33MB/sec) transfer speed.

If a new IDE cable still doesn’t help, you may need a hotfix IDE driver from Microsoft. Take a look at the this Microsoft Knowledge Base article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

This may help explain why the OS is constantly reducing the transfer mode to PIO, possibly due to CRC errors on the IDE bus.

If you would like to give this hotfix a try, let me know and I can email it to you.


#7

it would be nice if u can send me the hotfix to rabble@scarleX.com
im optimistic that this will work… hopefully :slight_smile:


#8

btw is it necessary to use the latest aspi driver in my case?


#9

Since you are using Nero, which comes with its own ASPI driver, there is no need to install ASPI separately.

I just emailed you the Microsoft hotfix IDE driver for WinXP SP1.

Good luck!


#10

ty i try it out maybe i report a little later cause of format C: :smiley:

who cares o_O


#11

this fix doesn’t work for me, do you think my dvd recorder is defective or is it more a software related problem … driver conflict or s.e.


#12

It is beginning to sound like your PX-708A may be defective, but there is no way for me to sure from over here…

Before you use the “Enable DMA” option in PlexTools Professional, you should ensure WinXP is reporting a “Current Transfer Mode” of “Ultra DMA Mode 2” for your PX-708A. The mode is reported under IDE channel properties within WinXP Device Manager.

Per my understanding, if you see the “Current Transfer Mode” reporting “PIO Mode”, it will be necessary to uninstall the IDE channel (primary or secondary), and reboot twice when prompted, before the transfer mode can be restored to “Ultra DMA Mode 2”. Once you see “PIO Mode” reported for the PX-708A, it means the OS has responded to either IDE bus timeouts or CRC errors by reducing the transfer mode to PIO. Uninstalling the IDE channel and rebooting to allow it to PnP again, rebooting a second time to get the drivers properly installed, should reset the transfer mode back to UDMA mode 2, at least until the WinXP IDE driver (ATAPI.SYS) responds to IDE bus problems again.

To see if the problem is located in the PX-708A or otherwise, you should do control experiments. Does the PX-708A fail the same way in a different computer? If so, the PX-708A is the likely culprit. Otherwise, try updating Nero to the latest version and uninstall other CD/DVD writing software to cut down on potential S/W conflicts.

I have a P4P800 system at work running WinXP SP1, with a Plextor Premium installed, and Nero as the burning S/W, and all is well.


#13

yes if i do it that way by uninstalling the ide channel in the device manager the current transfer mode shows after the reboot ultra dma 2 mode. so its for sure that its reported under ide channel properties. ill try the plextor tomorrow in another system.
do you think that the array is the point of my problem and will be solved when i use my 2 harddisk’s as single harddisks if its almost sure that my plextor is not defective?


#14

To see if the problem is located in the PX-708A or otherwise, you should do control experiments. Does the PX-708A fail the same way in a different computer? If so, the PX-708A is the likely culprit. Otherwise, try updating Nero to the latest version and uninstall other CD/DVD writing software to cut down on potential S/W conflicts.

rabble already mentioned he upgraded to the latest nero and it didn’t work for him. i don’t think the culprit is the 708 drive. he could have a software conflict and it has to do with the INTEL APPLICATION ACCELERATOR. It maybe best to reinstall XP without installing the INTEL APPLICATION ACCELERATOR and to only use microsoft drivers.


#15

i havent installed the iaa when i started this thread so that cant be the reason


#16

Rabble, I forgot to mention my P4P800 system also has a 2-drive RAID 1 (mirror) array, and IAA RAID Edition installed. The Intel IASTOR.SYS RAID driver included in IAA RAID Edition is the only driver that works with Intel ICH5R RAID, so it is not optional. The Microsoft IDE driver has no support whatsoever for Intel RAID.

This means your Intel RAID 0 array on ICH5R cannot be the cause of your problem. Changing your RAID array back to a pair of plain SATA hard disks is unlikely to resolve your problem. Your H/W and OS configurations are very similar to mine.

I just want to make it clear to folks that I have a total of three (3) WinXP SP1 systems (two ASUS P4C800-E boards with 875P/ICH5R and one ASUS P4P800 with 865PE/ICH5R) running with Intel ICH5R RAID and two SATA hard disks in either RAID 0 or 1 in each system, and a Plextor PX-712A, PX-708A and a Premium drive, attached to the three systems respectively, and PlexTools Professional 2.15 installed, with no problems whatsoever. This is proof that IAA RAID Edition 3.5.3 can coexist properly with PlexTools Professional.

The older Intel Application Accelerator (IAA 2.3 and earlier) S/W supported Intel chipset southbridges up to ICH4 but not higher, and has no RAID capabilities. It is this old IAA series that had more compatibility problems, especially with CD/DVD burning software. This Intel S/W is supposed to provide enhanced hard disk subsystem performance when it replaces the Microsoft IDE drivers, but due to said compatibility issues its use is NOT recommended.


#17

mhh im a bit helpless due to the fact that the plextor is burning correctly for its conditions under PIO Mode so i think it cant be defective…:confused:


#18

One more suggestion: Uninstall WinXP SP1 and install it again. It is possible that the ATAPI.SYS IDE driver may have become altered or corrupted, especially having gone through those hotfix installations. Re-installing SP1 for WinXP should reset the ATAPI.SYS driver revision back to the SP1 level.

The same Plextor in another system should provide a good data point.


#19

Do you have a special order for the installation of all your drivers for example direct x graphic driver chipset and so on…im a bit tired its 2o’clock in the morning here cya tomorrow hopefully with some more details :>


#20

ive tested it now in another system…it had the same effects under winxp like my system. it seems that its really defective, but the strange thing is that its only in udma2 mode NOT in Pio Mode.