Problem with TS-L532R

vbimport

#1

I have recently bought a HP Pavilion dv1000 notebook with a TS-L532R slim drive (writes all kinds of DVDs except DVD-RAM, max speed 8x). I have had experience with CD writing, but not with DVD writing.

I also bought several Memorex DVD+RWs (4x), and a 25 pack of HP DVD+R (8x) discs. The Memorex disc can be burned perfectly with all kinds of software (Sonic RecordNow! which came preinstalled, HT Fireman, Nero). However, I have already ruined four of the HP discs. I even tried reducing the writing speed in Nero to 4x, but to no avail. The odd thing is that the buring always finishes seemingly successfully, but then the disc is just plainly bad. Sometimes the directory structure is OK, sometimes not even that. I watched closely and couldn’t see any buffer underruns.

I thought it might be a firmware issue, but I don’t find any firmware updates for this drive. Maybe I’m not looking where I should. The current version is HA04.

Any kind of help appreciated.


David


#2

More information on the problem. The media type (as returned by DVD Identifier) of the Mediamax DVD+RW is [DVD+RW:INFODISC-A10-001]. The media type of the HP disc is [DVD+R:CMC MAG-E01-000].

Should I just buy some other kind of DVD+R disc, and try with that? Could that work?


#3

Okay, more followup. I bought a stack of Memorex DVD+Rs (I don’t remember the exact media type, but it’s a Ritek disc), and that works like a charm.


#4

Hi,

I was wondering if you still have the same problem?

I have a DV1207us laptop
spec:
1.3ghz Intel
512mb ram

and it came with the same L532R burner and I’m having coster left and right. I searched for a new firmware and it’s not available. I believe this is a Samsung drive and there is no support from Samsung on this.

I’m using TDK DVD-R [TTG01 and TTG02]. The only difference between the two is 01 is 4x and the 02 is 8x. I’m having problem with playback. I did a Nero DVDSpeed check and I have a bunch of errors when i do the Scandisk. I can’t do any other test. I read somewhere that your drive has to be able to return errors for the other tests to work so I can’t do that.

Anyways…I usually have to burn after a restart and usually at lower speeds. Even if i put it to burn at 8x, I think it still burns at a lower rate. After Nero tells me that my burn is sucessful, I take a look at the burned side and see a lot of transition problems (different color burn marks). So i lowered the burning to 2x and it gave me a pretty good burn but when i went to play back the file, it gave me errors. So i checked it on DVDSpeed and it had some errors in the beginning then a whole bunch in the middle.

Hopefully you figured something out. I’m going to call HP and see if i can get something else. I’ll keep everyone posted


#5

I haven’t written a lot of DVD’s since my last post. I did notice that the MEMOREX DVDs are written at 4x, although both the discs and the drive is 8x. But at least I didn’t have problems with playback. I’ll try DVDSpeed on them anyway, and see what it reports. Please let me know what you heard from HP.


#6

I too have Hp pavillion Laptop which came with TS-L532R drive. I have been having problems burning disks properly with my drive too. I used Samsung Pleomax DVD-R 8x, one i burned at 4x speed(with Nero 7) and 1 at 8x(with Record Now). Both got burned sucessfully, but when i verified the the data was corrupted in some sectors. Than I thought there was problem with media. So I tried Amkette DVD-R 4x media and burned it at 2X with Nero again. This time too I had bad and damaged sectors (about 0.1 % bad and 2.4 % damaged). Is this normal that DVD have damaged and bad sectors?
Or there is something wrong with my drive?


#7

Hi,

I posted in Vips thread but I’ll just type again.

Yeah I called Tech Support. I’ll write in more detail here.

Get this…
I call the 1800 number and I get an Indian guy on the phone. He tell him my problem with the drive and he says to me,

“Sir, did you download anything like music and software files from the internet?”

me:
“Umm…yeah, but there wasn’t a problem before. I’ve had this laptop for 6 months and I’ve downloaded plenty and it hasn’t had a problem until 2 weeks ago.”

him:
“Well sir, I will transfer you to a Microsoft / HP qualified Tech Support, but there will be a minimal fee.”

me:
“What? This laptop is still under warrenty. The warrenty is 1 year right?”

him:
“Yes sir, but because you have downloaded files from the internet that can corrupt your system, we are not responsible for that so there will be a minimal fee to speak to Tech Support.”

Anyways…after a big argument about how if he would listen to my problem…it’s not a software issue but a hardware one…and also that my system is perfectly clean…i hung up.
Called again and this time got another Indian person who was nice enough to just transfer me to Tech Support. The Tech support says that it looks like it’s a hardware issue but just to make sure, he needs me to burn a dvd with Windows Xp’s default software and if that give me problems, i have to format my computer and do it again to make sure that it’s really a hardware problem. First of all, Windows XP doesn’t have a default DVD burning program…it burns CDs. Second…is he crazy? I am not formating my computer. I have too much stuff in here to be doing that…it took me long enough to setup this computer when i first got it.

So in conclusion…not much luck with Tech Support. I had him search to see if others were complaining also and he did a search said that they haven’t heard much about it. Also, we have to send in out laptops to get it fixed because it’s not detachable. Man…this sux.

I’m using Nero 6.6.0.14 and using 8x media but it only lets me burn at 4x. Anyone else getting this same problem? Anyways…I’m trying different things so I’ll keep you all posted. Let me know if you figure something out.


#8

Ok, it seems I have the opposite problem than everyone else with this drive. I have a compaq presario v2310ca with the TS-L532R drive. I can burn DVD-R’s and DVD-RW’s perfectly but cannot burn CD-R or CD-RW. When I first got the laptop I could burn anything but now unexpectdly, CD-R and CD-RW’s cannot burn. I have no idea what it could be, I know its not the types of CD’s I’m using cause I’m using the same ones I did before when it worked and I have also tried other brands since it stopped working and none of them work.

I use Nero to burn and get the error messages “Invalid write state”, “Could not perform EndTrack”, “Illegal Disc”, and “Could not perform Fixation”. Another thing I noticed is that when I’m buring the CD’s, where it says “writing file” in Nero, it says READ. Usually it should say the file name of the file you are burning. I’ve also tried changing the DMA settings of the IDE ATA/ATAPI controllers. I have tried all different settings of transfer mode “DMA if available” and “PIO only”. I also noticed that for Device 1 current transfe mode is “Not Applicable”. I’m not sure if this is the problem but there does not seem to be an option to change this setting.

Anyways, with the posts I’ve seen here, it seems that these drives may be defective and HP/Compaq should all replace them free of charge.


#9

I have found that the Number one problem with DVD burners is sensitivity to certain types of media. Most amazingly My HPpavilion ze2113us with the TS-L532R WILL NOT EVEN LOAD TO BURN HP DISKS. I believe someone else noted they were CMC. I have been able to burn them with LITE-ON drives, but is was unreadable on a DELL laptop reader. MOST DRIVE FIRMWARE UPGRADES ARE TO ALLOW BURNERS TO BURN MORE TYPES OF MEDIA!!!. TSST does not seem to be terribly interested in this otherwise there would be a version newer than HA04. It would be nice, however, if we knew which media types and speeds they used when designing the drive. The problem is that they may no longer be available because they keep changing the formula for 2x, then 4x,8x 16x etc. Where can you buy 1x-2x disks except for Comp USAs cheepo store brand. A 16x drive was probably designed to write 16x BUT NEVER TESTED BECAUSE THE MEDIA DID NOT EXIST!!!.
I DO HAVE A FIX FOR ALL OF YOU PEOPLE WHO HAVE NOTICED THAT device manager secondary IDE drive current transfer mode says PIO. Its a XP bug from XP SP1 according to microsoft my computer shipped with XP SP2. Simply UNINSTALL the Secondary IDE driver (right click on device manager entry or select the DRIVER tab and UNINSTALL. Reboot the machine, it reinstalls the driver. Check to see that DMA Mode for Secondary IDE driver was selected and granted.
Good Luck


#10

Hi, I had a similar problem with a TS-L532R , only 1 out of 4 DVDs was recorded correctly, I’m using Nero, Roxio Easy CD creator, DVDShrink, UltraISO, etc.
However I managed to solve the problem by doing 4 things to avoid any possible conflict:

  1. Make sure DMA is enabled for the drive

  2. Disable any antivirus and do not run any other programs on the background

  3. Disable Windows XP CD recording capability on the drive
    -Open My computer
    -Right click on the DVD/RW drive
    -Select the Recording tab
    -Disable “Enable CD recording for this drive” it will not affect Nero or the other SW

  4. Disable autoplay

I hope this might help you.


#11

Yes, TSST’s OEM drives have a terrible firmware (after-purchase) support.
Of course, you should try high quality media like Taiyo Yuden, Verbatim or Sony instead of Memorex or HP…


#12

Ok… as everyone here i have the same problem. i onw a pavilion zv6000 with the same dvd and I have been able to partially solve it… so here is my contribution to the thread:
I used to burn without any problems on verbatim dvd-r. I even bought a 25 dvd pack and suddenly i was unable to burn on them. Since i took them on a plane i thought it maybe was because of the xray or something so i got another pack so the problem continued. I’m on Spain and HP won’t service my laptop since i bought it on USA and on the US thae asked me to send it there, which i refused to do. The other option was to get a new drive (in case anyone is intrested, the part number is 398032-001 and it costed me 45 minutes with an hp guy online to get it) but i read on a forum that even with a new drive the problem wasn’t solved so i started trying some things… here are my tests:

-I formatted my pc and the problem was still there without anything installed except windows and nero… so, don’t format because it’s useless… i just thought of something… wouldn’t it be possible that a windows update is making the error??? if anyone formats don’t install any update and let us know

-I made tests with many brands and models of dvds… and only succedded with 2, i got perfect copies using maxell dvd-r 1-8x (item 275517). the 16 x ones will give u the same prob! and also with verbatim dvd + rw 4x model 43228… i’m still making experiments, but if you can get those models you might be lucky as i am and forget about the issue
My other tries: verbatim -r on any speed, maxell 16x, tdk + r ALL 16 x so if you haven’t catched it yet you should try with low speed dvds and pray…

Also… i read someone saying that it might be a voltage issue… they said that maybe the voltage wasn’t enough and that was causing problems burning on 16 x… i believe it doesn’t make any sense but i’m open to anything and woud like to hear opinions from someone that knows.

hope it helps and maybe give an idea o someone… more to come if i make any new conclusions


#13

hello guys, so… I have the same problem, i bought that fuckin laptop in Italy (zd8156), paid fortune, and it doesn’t work, First was card reader, and then slowly DVD burner (OF COURSE TS-L532R!!!). The closest service was in Austria, so i sent it there. WAITED more then 2 months. and ufff they have changed main board (!!!)… card reader is working and dvd burner worked but only for first dvd… then still the same. Burning successfully… but dvd is empty. I’ve noticed one interesting thing… when i look at the track burned i see that it seems to be recorded in 2 sessions (two different reflecting light tracks). and the first one is always 1/3 of the full recorded part of dvd. i started carefully observe how it is burned. and i’ve noticed another thing. Nero is burning till the end (100%) and then starts from the beginning but this time burns only small part (let’s say 15%) and suddenly 100% again. Do you have the same?? look at the surface of burned dvd.

i decided that it doesn’t make any sense to send it again for another 2 months, where they will change this time e.g. processor and send it back still broken. i started digging in. I did what Marcialito did:
"1) Make sure DMA is enabled for the drive
2) Disable any antivirus and do not run any other programs on the background
3) Disable Windows XP CD recording capability on the drive
4) Disable autoplay"
and disabled Secondary IDE drive.

And under Windows it works!!! still nero makes strange acrobatics while burning and the dvd looks as if it was burned two times. but it works!
Now i need to only figure out what was that factor which really helped so i could do the same under my Linux Mandriva which also burns out all dvds.

however i think that we should do something so they could replace all our TS-L532R free of charge instead of doing tricky things just to somehow burn our dvd. Coz i am not gonna use only windows and forget about my computer for one hour while burning (i burned at 2x), switching off all programs like antivirs, winamp, web browsers. It really shouldn’t be like this!!!


#14

Guys … i Hawe the same problem … same TS-L532R dvd burner … and i have a CRC problem at the exact same 952 336 bit position (or how it is called) ewen if i am writing 4.3 Gb of data or only 2.3 gb of data … it is allwais at the same “place” crc error … and i Tried
Unique Disc Identifier : [DVD-R:FUJIFILM03] (Imation) 8x speed , and Unique Disc Identifier : [DVD+R:MCC-004-000]
Recording Speeds : [1x-2.4x , 4x , 6x-8x , 6x-16x] ( verbatim advanced azo+) sooo … i dont know what i am doing wrong … Defragmented disc, antivirus off, ULtra DMA on .

This burner is in my Compaq Presario V2000 notebook. And i am loosing fate …

is there any serious help ? or should i Try some other discs ?
I tried Imation DVD+R -R different speeds … and allwais the same result …

help…


#15

Clean the drive or RMA to Compaq.


#16

http://www.dougknox.com/xp/scripts/xp_cd_dvd_fix.vbs

You may want to try this. I have a problem with the same product. I uninstalled the device in device manager and then restarted. Then I went here and it’s been working fine since.
B


#17

Hi everyone,

Despite I am new here this bloddy TS-L532R is going to made me expert about drivers.

Let me tell my story briefly.

Like as everyones it stop suddenly the burning the DVD+R and DVD-R medias. Out of this it may able to write all types medias(DVD± RW and CD/R/RW)

I tried many brands :

-Gigamax, TDK, HP, Benq, Verbatim

I tried following softtwares :

  • Nero (vers 5, ver 6.6, ver 7.5), Sonic, Alcohol 120, Deep Burner etc

My all dma are available,

I do the necessary patches like xp dvd cd fixer

clean all classes (px20help)

formatting (3 times)

and do what advised here on the net.

I came to conclusion that the matter was not media matter. How.

Due to business I am living in egypt and took my laptop (HP DV 1000) to service.

They reply me it was software. I saw that it was formatted and and loaded Nero and it was working perfectly. Even able to write any shit brand. Then when I am going to make my usual updates I discover that they load on my laptop xp pro system. Due to illegal issues I should to return to xp home(come on this my first genuini o/s) and guess what happened ? same problem.

The only issue this time I just reloaded my xp home and my updates. No any other software was loaded except Nero.

So this was clearly showing that this caused by o/s. Also there is a great possibility of windows update patches and next time i am planning to test this matter.

The HP online service after trying third time they advise me to change my o/s. When I asked how they advised me to purchase xp pro. I asked them then why you are selling your products with o/s which is not compatible with hardware. reply is just silence.

So spending more medias and formulas will not work. even if worked it will be temproralily. (Sometimes it was burning with success this is mystery.)

My idea is most probably one of windows update was causing this problem but i didnt determine yet. I will try without updating my xp home and will advise you.

By the way if someone get solution for this issue i will name my child with his name :slight_smile: