Problem with SONY RW DW D-56A

vbimport

#1

Hi everyone,
I would like to refer my problem and maybe find the solution.

I bought a Sony Vaio laptop (VGN-A215M) one week ago. I found plenty of useless programs already installed on windows, so I decided to format my HD and install a fresh copy of WinXP professional.

Everything worked fine instead of the Sony optical drive.
My problem is that when I use NERO or any other program that uses my DVD-RW my computer becomes very very slow … unusable!!! My CPU usage is at 100%

I can’t even chose to write at 8X speed on NERO and it should be able!

I remark that when I’m burning a DVD (always with NERO) the read buffer is at 0% is this normal ? I had other burners and it alway showed 98-100%

When I use ShrinkDVD to buckup, my computer become also slow and I can’t even listen to some music.

I don’t know what’s happening !!! tried to find the solution on sony website but found nothing. Then I came here, I found some new firmwares but none changed the situation.

Does anyone know what could it be ?

Thank you

Impo


#2

Hello and welcome to CDFreaks.

The problem is that your drive is on PIO mode. Please open the device manager and change the properties of the IDE controller and you will see the option for setting it on DMA.

If you are unsure as to how to do this, please read this thread.

A 0% buffer is very bad for burning quality, and is generally solved by fixing the DMA setting.

(This is a pretty common problem with an O/S reinstall because PIO is the default setting.)


#3

I’ve already done that. I’ve changed it in “DMA if available” … but I can see underneath it - Current transfer mode: PIO Mode.

I didn’t think it was that cause I did’t take attention to the transfer mode since I’ve changed it in DMA at the first time.

Now the current transfer mode has changed in DMA after reinstalling and seams to work with CDs … tommorrow I will try with DVDs … I’m sure it’s going to work too! : )

Thank you a lot.

Impo