Problem with Soldier of fortune 2

This is the error message that appear when I try to load SOF2.
Full installed whit and whitout nocd patch!

Please help me!

Originally posted by sansones
[B]

This is the error message that appear when I try to load SOF2.
Full installed whit and whitout nocd patch!

Please help me! [/B]

i believe this is not a copy protection error (system error???) try it in another PC and see if it works

:Z
I had this same problem, I have WinXP… So I got a tip to re-install XP, now it works no problems w/ the back-up of SOF2

Several solutions found :

1
To solve the default.cfg problem, there will be a file called newconfig.cfg in the main folder, which you will need to rename to default.cfg and that will make it work.

2
Error: Couldn’t load default.cfg", it took me hours to figure out what was going wrong, and after locating a site that detailed this error I found that when I installed the server I didn’t have the pak0.pk3 file in the correct directory (i.e. the one I was trying to run the server from), so make sure you install to the correct directory and that all files are contained in the appropriate paths. The default.cfg file doesn’t actually exist, it is part of the pak file and the error message defaults to this when the pak file can’t be found.

3
Couldn’t load default.cfg
I’ve put a zero-length default.cfg file in the install directory.

This is the error i get

Can anyone help?

I havent got that file…

You could at least read the solution. Make a file called default.cfg with notepad or something. don’t put anything in it.

I had the same problem with Soldier of Fortune 2, i.e. Couldn’t load default.cfg". I tried all suggestions but eventually I uninstalled the game by deleting all the files (add\remove wouldn’t work) then searching the registry for every word, i.e. Soldier, Raven. Soldier of Fortune, Activision and any others I could think of, rebooting each time. I also deleted all prefetch files and when I had finished, IT WORKED!!! I can now play the game. The risk is, can YOU play with YOUR Registry?

After messing around no end i’ve found that this error is caused by you cd being scratched. SOFII will complete install even though its missing data.It doesnt display a cyclic redundancy check as most games do. Just compare your main data files on the cd to your installed ones musicandsound etc. For some reason SOF2 install skips bad crc. Lesson:Look after your game cds :iagree::iagree:

I’m sure they’re happy that you spent two years on their problem.

I got any error whit it install it say’s

Setup has detected a previously install version of Soldier of fortune ll- Double helix on this system.

Unstall Soldier of fortune ll- Double helix mp test before running the setup progam again.

But i have deleted erverything i can find anything more of soldier of fortune ll :S

If you know what for problem i got post me then.

Run regedit and try to find all the soldier of fortune, sof, etc. keys that might tamper with the installation. Make backups of the keys before destroying them.

hay im having a problem with sof2 double helix gold loading it loads initially but doesnt show the menu completely it only show the mods tab and it wont let me do anything…help plz