Problem with rebadged BenQ 1620

vbimport

#1

I just recently bought a Pacific Digital Mach 16 (a rebadged BenQ 1620) and have been having huge problems with it. Namely, it takes 1 hour and 40 minutes to burn a dvd. Yes, I am not kidding. I tried different write speeds in nero, nothing helped. I flashed it to the B7T9 firmware, same problem. I then tried to burn a cd image with alcohol 120, and the burner would only go up to 16x (instead of the 40x max i set it on). What could be causing this huge lag in speed?

My computer is pretty old, a Pentium III 450 with the first PIII motherboard (UATA 33). Does this have to do with the slow burns (the discs worked though)? I also noticed that my CPU usage is 100% when burning.

Please, can anyone help me out?


#2

This happened to me with a Pacific Digital Mach 16…Eventually the drive just stopped opening/spinning up, and I had to RMA it. However, I have a much newer computer than you do…

The replacement drive I got works fine(so far), so if you RMA it, you’ll probably get a working drive.


#3

Maybe im wrong but i would strongly recommend a new or upgraded pc.
There could be several reasons for this not only a faulty drive.
The Hardware is pretty antic and i have a machine thats not state of the art too.
Does the drive work with ata 33 ?
Could you check this with the nero info tool.
I would say the speed you need isnt given.
First thing i would try is the drive in a newer pc and if it works then you have your answer.
Ok you could rma it too but the same thing could happen again.
(I tried to run a nec burner on a PIII 500 with a ram shortage and via chipset that was not funny lol)


#4

You really need a new PC!!!


#5

Welcome at cdfreaks :slight_smile:
As you know, your PC is quite slow, but it could burn at 8x if you have some luck. Post the result of the Nero CD-DVD Speed burst transfer test. Usually it is 23 MB/sec, you might see 18-20 MB/sec on your slow pc. Check your DMA settings (also on your hard disks).


#6

Your drives are in PIO mode … and you are probably running win98 or winme.

For windows 98, right click on my computer, and select properties. Then select the devices tab, and under drives (Hard drives, or/and CD Drives) double click on each device and make sure the DMA checkbox is checked under the properties. You need to check the hard drives AND the DVD burner, since windows 9x doesn’t ussually enable DMA by default.