Problem with QSI DVDRW SDW-041

vbimport

#1

Hi,

there is no problem with burning cd’s at 16x speed. But i am not able to write any DVD. When i insert a DVD+R nero sais that i should insert a media DVD+R/RW.

Any Suggestions ?

Dennis


#2

Humm… If the device is correctly recognized and is working nicely with CDs, it seems that it cannot find the media inside.

We will investigate what’s up with this with this device and keep you informed as soon as possible.


#3

Thank you very much. I never used Windows on this machine so i can’t tell you if the device would walk with nero on Windows. I also can’t burn DVD’s with growisofs/k3b, it’s the same error. Perhaps the device has an error.

I am living near to Karlsbad, so if you don’t have the device to test it i can com over there :wink: :wink:


#4

AH! Sound interesting… Have you tried to flash your firmware ? Sometimes bad firmware can cause trouble with medias. Have you already tried with other DVD+R/RW from other brands ?

Don’t worry for that. We also have one :wink: . It is a slim drive for laptop I’m right ?


#5

I never tried to flash it. It’s a brand new FSC Amilo L 7300 Notebook.
I have tried the BlueDisc and Verbatim Medias with the same result.

Don’t worry for that. We also have one . It is a slim drive for laptop I’m right ?

Oh yes, you are not an OS-company :wink: Yes it is the slim one…


#6

I’ve just made a quick test with a Verbatim DataLifePlus DVD+RW 1-4x. I just burned 1.5GB of data on this DVD+RW and everything went fine. I will give the device to the QA so that a more deeper test can be performed.

BtW, Can you give me some details about your Linux system:

  • Distribution
  • Kernel (uname -a)
  • Firmware revision of the device

#7

I do not have DVD+RW medias, only DVD+R. So i try to use Verbatim Datalife DVD+R.

I use a Fedora Core 3 with Custom Kernel (2.6.11). Don’t know how to find out the firmware revision. I think i will try to install Windows and try to burn a DVD. Let’s see what happens.


#8

Here you can see a screenshot when i insert a dvd+r

Edit: The burner also should write 4x speed




#9

I just recieve some news from QA. It seems that your problem is somehow chipset dependant. On some machines it is working (quite) nice, on some others the burn process just fails. In order to get the firmware revision, just reboot your machine and use this old ide-scsi bridge with your device. After that, just attach the proc/scsi/scsi file so that I can see all details.

Maybe it would be a nice idea to test what is happening under Windows… but I think you will get the same result.


#10

I am not sure about that. I couldn’t start yet installing Windows. I had different problems already because of the chipset which where solved by the kernel team. I think i will give it a try with windows (just a try, won’t use it :wink: ).

How can i use the ide-scsi bridge ? Just insert it in the kernel boot-options or what ?

Thank you very much,

Dennis


#11

Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: QSI Model: DVDRW SDW-041 Rev: DU07
Type: CD-ROM ANSI SCSI revision: 02

Here we go. Hope that there is a possibility to update the firmware with linux


#12

Looks like we have the same device with the same firmware. I will keep you informed ASAP.


#13

Thank you very much


#14

Are there any news with my model ? :slight_smile:


#15

Busscan currently under progress… A good point is that your device is also erroring under Windows :stuck_out_tongue:


#16

ROFL, not really ? I think i should try it myself with windows. You don’t use the same Notebook, do you ? FSC Amilo L 7300, they have put Nero (for Windows) on the hard disk but i never tried it G

When i install Windows on an external USB-Disk, will it change anything to the Bootblock or something ?

In my Notebook there is a VIA Chipset. K8N800 or KN800 or something…

Regards,

Dennis


#17

No we are not using the same notebook… Of course. But we have some small electronic parts that allow to burn a slim drive on the IDE channel of a motherboard.

Simple question… NeroLINUX does not warn you at startup that DMA acceleration is not enabled on your recorder ?


#18

No. I do not get any warnings.

Edit: But something seems to go wrong. The Output of hdparm /dev/hdc:

[root@nb-dschwan ~]# hdparm /dev/hdc

/dev/hdc:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Invalid argument


#19

Nothing is wrong in your output: It is a CD drive, not a HDD ! Just add -i to get information about your device…


#20

Alright…

[root@nb-dschwan ~]# hdparm -i /dev/hdc

/dev/hdc:

Model=QSI DVDRW SDW-041, FwRev=DU07, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no

  • signifies the current active mode