Problem with Plextor PX-712SA/SW & media

I bought this great burner a few months ago. It has been doing a great job for me until today. I am not sure if it just does not like the media or what.

What has worked for me in the past:

Maxell DVD-RW
Memorex DVD-RW
Vertabatim CD+R

What is not working for me today:

Memorex DVD+RW

I figured since the Memorex CD-RW worked , then the Memorex DVD+RW would work.
This is not the case. I wanted to use the plus for RW’s because the speed is 8x, vs. the 2x with the minus.

What seems to happen is, I get a burn error every time. The burn does not even start, no blinking orange light. When I open plextools and tru to do a quick or long erase, it tells me the disc is unformatted and does not need a erase. Do I have to format the disk or something? If so, how? I have never had to do that. Most of my burning software will say formatting in the beginning of the proccess. Maybe the Memorex DVD+RW are just not compatible?

My main question:

I know you guys have a lot of knowledge on burners. What is the best + and - dvd’s for rw and also r? I just dont want to waste my money on dvd’s for them not to be compatible with my: Plextor PX-712SA/SW. It’s the SATA version.

Thanks in advance!

Chris

bump, does anyone know of the best media for rw + and - and r + and - for my plextor?

Most DVD+RW and -RW are not on par with DVD±R write once regarding the burn quality. However, I would recommend Verbatim 8x DVD+RW once they are out in the market. But keep in mind that they are only good for a few burns.

Good DVD+R/-R:
DVD+R: Taiyo Yuden (Fujifilm, Sony, TDK; all made in japan), Verbatim, Maxell, Ricohjpn
DVD-R: Taiyo Yuden (Fujifilm, TDK; all made in japan) and Verbatim


Edit: the Verbatim 8x DVD+RW (MKM.A03) is not supported yet by the current firmware 1.07 so never mind about it.