Problem with Panasonic DMP-BD30

vbimport

#1

Hello everyone I own a Panasonic DMP-BD30 and I have a odd issue. Originally I owned a cheap Pioneer DV-260 and I could play all my DVD-RW backups on it. I would remove the menu, extra audio, and subtitles and make ISO backups of my discs via HDD/FTP.

My problem is now all my backups wont work with this player, it will go in and after 7 seconds say “cannot play”, however if I use a edited DVD WITH the main menu it will play just fine. Is it possible to get past this by making a menu and if so how do I do it? Logical step is to re-rip my collection but over the years I either lost or broke some of the originals and I have a total of 5 DVDs I no longer have the original disc for. I don’t need a fancy menu, just enough to bypass this stupid error message.

I use Verbatim DVD5/9 and I used DVD Shrink and RIPIT4ME to make the ISO. I stripped everything but the movie file then turned into ISO and compressed on a 1TB HDD.

Thank you very much for any help you can provide. I appreciate it.


#2

If they’re normal DVD Video discs and you processed them with RipIt4Me and DVD Shrink then it shouldn’t matter whether there’s a menu there or not.

Perhaps your player is a bit fussy with rewritable discs.

Try copying one onto non-rewritable media and see what happens.

[B]Wombler[/B]


#3

That is the odd part though…same process WITH menu it works each time (20 DVDs tested) and out of the 5 DVDs with out menus = disk error. I am going to try a firmware update tomorrow as I know it doesn’t have the 2009 update.

Thank you btw for posting on my thread :slight_smile:


#4

No problem. :slight_smile:

That’s weird though as the player should read the “First Play PGC” instruction and play whatever it’s pointed to regardless of whether it’s a menu or other titleset.

I’d go ahead and update the firmware as this could be a known issue with your existing firmware and I see a lot of the firmware updates for this machine have been for stability/playability reasons.

The current version is 2.9 and you’ll find it here.

[B]Wombler[/B]


#5

Yeah I updated today and it worked but the same error popped up. Got me really happy as it booted it up to play and I thought I found the fix. I might need to buy a cheap DVD player at this rate. I am using DVD-R+ discs and I dunno if trying DVD-R- would do anything at all. I tried calling Panasonic and they pretty much said “dunno” in 45 minute conversation.

I also tried making a menu using this little confusing FAQ :stuck_out_tongue:
http://download.videohelp.com/r0lZ/pgcedit/third_party/r0lz/still_frame_menu/still_frame_menu.html

Not sure if I 100% did it properly but I did make a blank menu that if I hit “enter” would start the DVD on my DV-260 player, but the same problem on the blu-ray with play error.


#6

PgcEdit is great software but you’re into the really complicated territory when you’re generating menus from scratch and it’s something I’ve never personally tried.

Are you booktyping/bitsetting your DVD+Rs to DVD-ROM?

[B]Wombler[/B]


#7

I am not sure…I use Nero and the default which I believe is ISO 9660+ Joliet which is suppose to be the “standard” ROM


#8

[QUOTE=Therian;2591499]I am not sure…I use Nero and the default which I believe is ISO 9660+ Joliet which is suppose to be the “standard” ROM[/QUOTE]

On every recordable DVD there’s a data flag telling players what type of disc it is.

Bitsetting, or booktyping as it’s also known, is changing this disc type info from DVD+R (or +RW) to DVD-ROM and this is done for compatibility reasons.

Basically it fools the player into thinking the disc is an original pressed DVD which has a higher degree of compatibility with more players.

Not all writers support bitsetting but if yours does then you should turn this on permanently.

In Nero, go to the Recorder Menu >>> Choose Recorder and if necessary click the Options button to make the options at the bottom visible.

Change the booktype setting to DVD-ROM then try burning your disc again.

This will only done to DVD+ media as the specification for DVD- media doesn’t support bitsetting.

[B]Wombler[/B]


#9

I see, I did just that and I am currently burning one of the files now to see if it works. I buy Verbatim DVDR+ disks I believe off Newegg, never had a issue with them so I keep buying what works (plus get them for $15 for 100 on sale)

Thank you for the help Wombler, with luck this is what is needed to fix this.


#10

Well hopefully it does the trick but I’m only guessing the cause so fingers crossed. :slight_smile:

[B]Wombler[/B]


#11

Yeah it kinda went the way I thought it would, it didn’t work. My problem is the player and I was 90% sure when I made this thread. I will need to fix the DVDs instead as nothing worked and it always works with the menu.

Thank you very much for your help.


#12

Okay then, plan ‘B’.

I was hoping we could get around this as it’s more work for you but it looks like you’ll have to reauthor the discs with a menu.

DVDFlick is an easy way to do this as it has a number of basic menu templates built in and it’s freeware so have a go with it and see what happens.

[B]Wombler[/B]


#13

Work is not a problem as my little Q6600 is a work horse.I will test it out when I get home but I do have a question, will it convert or edit the original file? I tried other programs (not dvdflick though) and it would convert the video. This made a very poor return after it was done.

edit
well I tried at lunch and I get “has no usable video track” this happens on 3 of the 4 vob files. The first one works just fine however and is added to the list. I tried adding as ISO and VIDEO_TS and each provided errors.

Going to try another DVD later when I get back and see if that provides problems as well.


#14

The video is already MPEG2 compliant so go to Project Settings >>> Video >>>> Advanced and check the ‘Copy MPEG-2 Streams’ box.

[B]Wombler[/B]


#15

Same error with the above enabled. Keeps saying I don’t have a video track that is usable on the other 3 VOBs which is really odd. Works just fine in other DVD editing software but it doesn’t really work well with other software as it reconverts a crappy quality.


#16

It’s possible that it’s not detecting all the video because the VOB files are split.

Run them through VobMerge first and see what happens.

Unfortunately I’m not sure why it’s still converting even though you’ve told it not to.

If they’re normal VOBs, which it seems they must be, then this shouldn’t happen. :rolleyes:

[B]Wombler[/B]