Problem with newer DVDFab mobile output... black bars on side

Hello,

I have been ripping my DVD collection to 720x480 mp4 (h264 aac). I have noticed in the last couple months that my rips are starting to show black bars on the side (similar to the widescreen bars at the top and bottom).

I fired up my old desktop which has DVDFab version 5.0.6.0 from September 2008. I ripped one of my DVDs that was having the weird black bar problem using the exact same profile as I do on my primary PC.

The black bars did not appear on the side of my mp4 output.

I will have to do some testing to determine which version this broke in. However, I am getting extremely fed up with the problems in this program.

At first I thought the attention the devs give to this program, evidenced by the frequent (2 or 3x a month version upgrades) was a good thing. Now I am 100% against it. I continue to experience new problems with my rips. They are subtle issues that I don’t notice immediately but its a huge problem when I’m ripping a DVD collection of 100s of titles.

My suggestion to Ting and Feng is to release one update a month or every two months. Hire someone to do some testing and work out the bugs before you release a new version. QUALITY CONTROL.

My only solution now is to downgrade to previous versions and at this point I want to completely ignore the prompts to upgrade. Why break something with a new release when it worked fine with the old release?

I’ve been suckered into thinking newer is better-- upgrade when there is a new release. I upgrade every other program on my PC when a new release is available without a problem. This is the only program that breaks with each new release. Subtitles stop rendering, weird black bars appear, aspect ratio screws up, ripping speed slows down, etc. I just can’t take it anymore. :a

Check your crop settings it is not the program it is the settings you are using.

Buzz
Also check the settings on your player. If you have auto cropping turned on and you can see a yellow line all the way around the image on the crop settings page or the Advanced Resolution Settings page, then DVDFab is not encoding black bars, your player is inserting them because the aspect ratio encoded does not match that of the player. Try playback with VLC media player for test purposes. Its window will show you what was encoded unless you resize the window by dragging a corner or side.

Thanks for the tips. I have autocropping turned off. I do not crop.

Also, it shows the black bars on the side in VLC media player and windows media player classic without resizing anything. It’s not just on my player that it shows up. Its actually a problem with the encoding of the file.

List some of the DVDs that produce the black bars. If I have them I will try them too and see what they do for me. Also need to know the exact device and profile you are using, i.e. iPod 3G, iPod 5G etc. Autocropping does not crop active video, only the black bars that are encoded with letterboxed movies.

Hi Signals,

Yeah I understand what autocropping does and how it works. I just elect not to use it. If I have a widescreen movie, I want the black bars there.

I’m using the zune.h264.aac profile. The only modification I made to it is to add another resolution to it (720x480).

Here are some DVDs the issue occurs with. There are tons more, I just don’t have my list in front of me: Pineapple Express, Righteous Kill, and Brave One.

640x480= no bars
720x480= bars

I have confirmed the problem does not exist with version 5.1.2.2 (Dec 2008). The very next release causes the problem, starting with version 5.2.2.2 (January 2009).

Testing was done using the same profile ripping Pineapple Express.

Clearly this is a bug and a problem with every release after 5.1.2.2.

I am very curious about this because I use a similar profile for my cellphone and Archos and have not seen this. I do get black bars on the top and bottom on both devices with 2.35:1 movies as would be expected, but not on the sides. I will try to run down a copy of Pineapple Express today and see what it does.

Hey signals, pretty much any widescreen movie I pick has this problem with anything above version 5.1.2.2. Also, the key difference b/w your Archos/cellphone and my h264.aac zune profile is the 720x480 resolution I rip at. I imagine the problem doesn’t exist under smaller resolutions.

Just to clarify, the normal top/bottom widescreen is not what I’m complaining about. It’s the black bars on the side that started appearing in the January release.

Looks like now I have to go back and rerip everything I ripped in January. Fun!

[QUOTE=buzzin1999;2213942]Hey signals, pretty much any widescreen movie I pick has this problem with anything above version 5.1.2.2. Also, the key difference b/w your Archos/cellphone and my h264.aac zune profile is the 720x480 resolution I rip at. I imagine the problem doesn’t exist under smaller resolutions.

Just to clarify, the normal top/bottom widescreen is not what I’m complaining about. It’s the black bars on the side that started appearing in the January release.

Looks like now I have to go back and rerip everything I ripped in January. Fun![/QUOTE]Why would you want to change the orginal "Native " resolution? You are not croping so natrurally the extra on the ends is going to be hard coded with black bars, so any player will show black bars all the way around when done full screen.

PAE is 2.40:1 anomorphic. One of the things I really like about DVDFab is that you do not have to mess with screen resolutions. Other programs i have used will actually do what what you asked it to do and that is change a 576x240 to a 720x480 making everything distorted. OBV that DVDFab is smart enough to not distort and adds the extras on the end.

Try ripping @ 576x240.

Buzz

Does the attached look like what you are seeing? Including the vertically stretched look to the picture? This is Pineapple Express encoded at 720x480, captured from VLC.


If it does, you can correct it any one of three ways:

[ul]
[li]On the Advanced Resolutions Settings screen, select "Zoomed by Source aspect and encode at 720x400 (see the capture below, black bars top and bottom, aspect 1.78:1).
[/li][li]Manually select automatic cropping, select “Supported by Device” and encode at 640x272 (see capture, no black bars, aspect 2.35:1 same as source)
[/li][li]Leave cropping off, select supported by device, select a 2.35:1 aspect screen, use the “resize” slider to eliminate as much or as little of the black bars as you like. (This has the same effect as the second step above if you set Resize to 100%, so there is no capture of this).
[/li][/ul]

All of the movies you had trouble with that I could check were anamorphic widescreen transfers with aspect ratios of 2.35-2.4:1, so to make the above steps work you would need to add some 2.35 sizes to the list in the Zune profile, which I did and used for all the tests. The methods with no black bars are more efficient since you are only encoding active video, not black. Your player may introduce its own black bars if, like the Zune, its native screen aspect ratio does not match what was encoded, 2.35:1 in the examples, but these should be on the top and bottom only. Automatic cropping and zoomed by source aspect should also work with these.

The 720x480 output (1.5:1) for some reason prevents the anamorphic original image from being corrected properly. This may be what has changed from the earlier versions, but I did not test it.



signals that does look like what i see, distorted and black bars. so what resolution are dvds at natively? during my testing i have always found 720x480 to look best on a big screen tv.

i also noticed the black bars on the side dont show up at 720x400, but at that resolution more than half of my TV is covered by black bars and it looks like crap. at 720x480 it adds considerably to the size of the vertical size of the picture without distorting it (again this is in the older version… the newer version screws it up by placing the black bars on the side). my fix is to continue using the working old version so i can rip at 720x480 without having these issues.

[QUOTE=buzzin1999;2214700]signals that does look like what i see, distorted and black bars. so what resolution are dvds at natively? during my testing i have always found 720x480 to look best on a big screen tv.[/QUOTE]
Let DVDFab do the thinking for you. Set to auto crop and let DVDFab choose its own settings. You are not trying to upscale with this program but you can get very close to the orginal DVD quality, remember this is a copy program first and formost.

why would i want autocrop? i happen to like the top black and bottom bars that indicate its widescreen.

[QUOTE=buzzin1999;2214726]why would i want autocrop? i happen to like the top black and bottom bars that indicate its widescreen.[/QUOTE]They will still be there, they just will not be hard coded to the movie. When you crop it dose not effect what you see on your screen.

There is no reason to encode blank space into your movie.

ok that makes sense. i’ll give that a shot and see how it comes out!

[QUOTE=buzzin1999;2214819]ok that makes sense. i’ll give that a shot and see how it comes out![/QUOTE]

I think I found the problem as I’ve been having the same issue. The problem lies in when you did “set as default” way back when to save your profile for how you want generic to encode. Obviously there were some backend setting changes and when you use your “default” to encode it is not cutting out the black space as desired. To fix it, just choose a new profile (I use generic.mkv.h264.audiocopy) then apply your changes (I change the bitrate to 1800 fixed, and the subpicture to direct render)…then choose “set as default” again…and wala…the encodings now look the way they are suppose to.

I guess as a good standard, you should do this after updating DVDfab everytime…otherwise risk the problem happening again…and you having 47 DVD’s to re-encode now…like me.