Problem with new OCZ PSU

Hi,
i recently bought a new powersupply after experiencing some sluggishness and an occasional system shutdown with my old PSU. Turned out the fan had packed up so i bought a OCZ PowerStream 520w ATX2… after installing the new psu exactly how my old one was assembled, the green motherboard light apears, but the power button on the case appears to be dead… So i checked back with the old psu and it worked fine…
can anyone shed any light on this?

ps: my old psu was a QTEC 500w atx

tnx

move the on/off switch which is above the red sticker ,if you have a 20pin motherboard have you connected the 4pin atx12v plug? other then those i dont know if its not any of em then ask in the offical ocz forum
http://www.bleedinedge.com/forum/forumdisplay.php?f=45

have tried the on switch, only the green light on the mobo appears, and i have the 4pin atx attached too…

does the system start up at all? even if for a second? Do fans spin up then down immediately? The OCZ psu’s are very sensitive to grounding and will not power up if there is a grounding issue. Be sure to check how your system is mounted and be sure to use all brass standoffs. The psu must also have a minimal amount of load before it will start but seeing as though you have your system hooked up to it that should be enough. A last thing you could try to do is remove the psu from the system completely and try and jumpstart the psu out of the case. If it starts then then the problem lies somewhere in your system. If it doesn’t im afraid to say the psu may be DOA. OCZ do have incredible customer service and will get you out a new psu if that is the case. They will even cross ship if you live in the US.

Here is the method to try and jumpstart your psu.

http://www.bleedinedge.com/forum/showpost.php?p=47553&postcount=5

stick a looped wire into the black and green pins and you should be set.

Also check OCZ official forums if you haven’t already for direct help on your issue.

http://www.bleedinedge.com/forum/forumdisplay.php?f=45

Hope that helps.

so i dont plug in the large ATX plug?