Problem with new BenQ 1650

vbimport

#1

I just bought BenQ 1650 with an external enclosure for an external DVD drive for my Sony laptop. My laptop however didn’t recognize the drive and the drive didn’t show up on Disk Drives nor My Computer.

However, when I turn on the drive (the fan turn on also), my computer made the sound of Window XP Hardware Insert and when i turn the drive off, the computer made the sound of Window XP Hardware Remove.

I’m pretty sure I had the jumper in master mode.

Please help me :bow:


#2

what’s the chipset on the enclosure?


#3

I don’t really know. How do you know?
Here’s the link to the enclosure that I bought

Thanks for helping


#4

Welcome to cdfreaks an9891gel. :slight_smile:

What’s the model of your Sony laptop?

I’m pretty sure I had the jumper in master mode.
Jumper position doesn’t matter when drive is in USB2 enclosure.

Most probably a Cypress.


#5

i’m not much of an external enclosure person, but I’ve read about BenQs not being compatible with certain chipsets. I think people have had good luck with anything with a Prolific chipset.

a search might turn up some of the comments that have been made in this forum regarding BenQ drives and enclosures.


#6

reasonsnotrules, you’ll not find that many enclosure tests with DW165* drives.

But chas0039 made an extensive test with 1655 among others in this thread. :wink:


#7

Do you know the reason why my laptop doesn’t recognize the drive?
Because it’s weird how it made the sounds


#8

Not to be rude, but please answer questions asked first. :slight_smile:

What’s the model of your Sony laptop?


#9

this was the thread i was thinking of…see post # 3 in particular http://club.cdfreaks.com/showthread.php?t=179598&highlight=benQ+enclosure


#10

Hi :slight_smile:
"IC (Chipset): Cypress (CY7C68300A-56PVC)

Supports HDD Capacity: 5-250G

Interface: USB2.0 B

Power supply: External power

Material: Al & Mg alloy "
Take a look here it may help.


#11

I’m so so sorry. I thought I post the model alreaydy.
Anyways, my laptop model is Sony PCG-GRT260G.

Thanks zebadee for the link. I went there but it didn’t help either but thanks anyway.


#12

Look like you are lacking a USB driver or incompatability of your external enclosure and your Motherboard. If the enclosure interface is USB 2.0 and your M/B bios is only supporting USB1.1 then you might have problem. Try to update your M/B bios and install the both USB 2.0 & 1.1 driver and see if the problem goes away.


#13

Hi TCAS!
How do I update my M/B bios and install the USB driver?
I’m really new at these things so please forgive me


#14

I would not suggest updating your notebook motherboard until you’ve tried other ways to get your drive recognized in your notebook via the enclosure. Check the SONY website before even considering flashing your mobo.

If you have XP PRO with SP2 the USB 2.0 drivers are already within the windows operating system. Update the USB Controllers by going into the Control panel then click on performance and maintenance >click on system then on the hardware tab then click on device manager. Look for Universal Serial Bus Controllers you will see the USB Universal Host Controllers. Right click on it then select UPDATE DRIVERS. See if that will enable you to see your new 1650 drive that is in your external enclosure. You could also check the SONY website to see if your notebook has a new driver for USB 2.0. If it doesn’t support USB 2.0 then you’ll have to get a notebook USB 2.0 card. I’m not even sure if one exists for a notebook.


#15

Hi! DVD ADDICT
I tried your way and went to the USB Controllers but the problem is I couldn’t find USB Universal Host Controllers.
Does that mean that my computer doesn’t have USB 2.0?


#16

Unfortunately there is no external firmware version for the BenQ 1650. BenQ drives has problem with most external enclosure chipset unless the firmware of the dirve is specifically designed for external use. So not much you can do there but wait and hope benq launch an external version of 1650 that way you can cross flash your benq to the external version fw.


#17

Your laptop does have 3 USB 2.0 ports. Do you have XP HOME with SP2 installed? Usually USB 2.0 drivers are there when SP2 is installed. In HARDWARE> DEVICE MANAGER the USB controllers look like this>



#18

In addition to DVD_ADDICT’s post above, this page might be of interest. :wink:
For Intel based mobo’s there is also an Intel USB Check proggy.

We don’t know what Win-XP version or SP an9891gel is on right now, but installing/updating USB drivers might also help. Search for KB822603 at M$.


#19

Hi,

you’ll find anything you need on http://esupport.sony.com/US/perl/model-home.pl?mdl=PCGGRT260G

Apparently this notebook is equipped with SiS chipset. :Z Crappy USB functionality with this.

Michael


#20

I’m pretty sure my laptop has SP2 installed since I tried installing KB822603 and they say my laptop has the higher version of the SP.
I also used the intel USB check and this is the result

Microsoft* Windows NT* with FULL USB support
Recommendation - No system software upgrade required

System hardware has USB support
Recommendation - No system software upgrade required

USB driver connection is operating correctly

I also attached a picture of my USB serial bus controllers and a picture of my Disk Management

When I turn on my External case, “USB Mass Storage Device” appear in the USB controllers

This is very strange

I also set my BIOS to default value but still no hope. I wonder if it has something to do with my external case being defective.