Problem with Nero CD Speed

vbimport

#1

Can someone help me with this problem:

Nero CD Speed keeps recognizing the wrong disc size. I'm using a Plextools disc since it's exactly 74 minutes (333.000 sectors) long but Nero CD Speed sees it as 60 minutes. I've tried other discs but all are recognized with a too small disc size. I've tried other recorders and the same problem occurs. CloneCD tray isn't running so that can't be it. No other programs running that could be effecting CD Speed (I've always had these programs such as ZoneAlarm running with previous tests). Blank discs are the only disc that are recognized with the right size... If I try data CD's (pressed/CD-R/CD-RW) they're all recognized with a too small disc size.

Any ideas?? I've also mailed Eric Deppe (creator of CD Speed) but haven't received an answer yet (just mailed him).

Thanks in advance!


#2

I have found the solution and Erik Deppe has confirmed it. WriteCD-RW! Pro was causing the problem:

WriteCD-RW! from Software Architects has a serious bug which causes this problem. To read Mt. Rainier or other UDF discs it makes sense to translate some commands (such as the command to retrieve the disc capacity), but this should definitely not be done with non-UDF discs.

It’s also not necessary to translate these commands with Mt. Rainier compatible drives because this is already done by hardware/firmware.

CloneCD uses its own driver instead of ASPI to access the drives directly so that can explain why it is not affected by this problem.