Problem with my Airlive repeater (WN- 350R)

I configured my Airlive router to act as a repeater and this is what i have done as you can see in the images below. Everything works great when i finish the setup but after one day from setting the repeater i can’t connect through the internet. i have reseted and reconfigured my repeater over 20 times but nothing worked it me, it only works for one day and then stops working.

I know that the repeater and the router that i want to repeater it should be in the same channel. Automatically when i select the router (drink) the repeater will set its channel same as the routers channel which in this case channel 8.

In the last capture as you can see i can’t connect to the internet…

i don’t know what is the problem even though i followed the official instructions to configure it as a repeater.

No encryption? Dangerous! I recommend WPA2.
dlink as ssid? Too Generic. I recommend a unique name, like OWAZIO or something.

Anyhoo. It seems your setup is ok according to the FAQ. Perhaps your Airlive can’t sometimes find your base wireless router?

Ok, finally i have figured out the problem and i feel bad that i didn’t get it from the beginning -.- lol

Anyway, the problem was simpily when i unplug the router from the power source, the repeater can’t recinfigure itself automatically and i have to reconfigure it again manually so i have to make sure that the router is NEVER unplug or shut off. However, sometime i need to close the internet for a while for certian option configurations, now that is a problem since i have to configure my repeater every time my router is disconnected but the good news is that i have 2 routers and it will overcome the this problem, this is how i setup my home network.

1)First thing i will start wit the names of my 2 routers and repeater.

A) Speedtouch (main router)
B) Dlink Dir 655 (secondary router)
C) Airlive (repeater)

  1. Setting up my home network.

My main router “Speedtouch” is connected to my secondary home telephone line and i connected "Speedtouch"to Dlink through an ethernet cable and whenever i need to close the internet i would close “Speedtouch” by switching it off either by unpluging from the power source or switching it off from the router’s button on the back. this will cause Dlink to disconnect but will will not be “turned off”. As a result, there is no need to reconfigur Airlive if Dlink has been disconnected without shutting it off.

I just want to clear things out, i figured out the main reason why my repeater isn’t working is that because when i shut off Dlink router the channel of Dlink router will be changed and it will change each time i turn it off. Thus, i have to prevent it from selecting random channels, this simply can be done by adjusted Dlink network settings.