Problem with Matshita UJDA740 DVD/CDRW drive

Hey I’ve got a problem with my cd burner.

When i try to burn cds with itunes, media player etc it comes up with the message: “disc burner or software not found”, or something similar. I’ve downloaded the driver for my cd burner a Matshita UJDA740 DVD/CDRW. When i try to open it a message comes up :“supported drive is not connected”. It has also disappered from the ‘my computer’ folder. Sorry I’m a novice with all this. My OS is XP home.
Any help would be much appreciated.

cheers
joe

Ok First thing to do would be to check that the Cd drive is still connected to the pc via the IDE wire or Sata cable.

2)Go to the windows "Control panel". On the top line you have add remocve hardware, add remove programs ect ect. You want to go to “adminstrative tools”. Then computer management. This should bring up a box with 3 main tabs on the left hand column. Click on “storage” and then “disk management”. This will give you a list at the top and a graphical interface at the bottom. At the bottom it should list you Hard drives and CD drives. Is the Cd drive you want to burn to their??
and if so has it been allocated a drive letter (check image below)
If not you will have to right click on the drive and click on “Change drive letter or path” And then choose a latter for the drive restart the computer and it should work.

if not post back


Hi, thanks a lot for your help. The computer’s a laptop, so the cd drive is internal. Is it still easy to check if the wire/cable is connected?

I followed your instructions and got to the computer management folder, but the only drive listed was the Harddrive (C: ). The DVD/CDRW wasnt even there! Does this mean I have to reload the cd drive onto the computer somehow?

here’s what my computer manag folder looks like:

Again, thanks for your help and i hope i can get this sorted out!

edit: sorry i dont know how to make the screen shot bigger

bump

if anyone could help, cheers :slight_smile:

bumppppp???

im still stuck, any help would be appreciated :slight_smile:

Then please don’t “bump” threads.

Open Devicemanager, uninstall both IDE channels under “IDE ATA/ATAPI Controllers” and restart. After restarting, check that DMA is enabled for all drives.
If that won’t work then replace the IDE cable with a new one.

Thanks for your help.

I uninstalled the two IDE channels and after restarting the computer, the cd drive came up as as ‘new hardware’. I was then asked to restart the computer again to finish installation of the drive. However when the computer rebooted, the cd drive wasn’t there!?

I disabled the channels again and repeated the process and the drive is installed but is not there when i restart the computer again.

In the properties for each IDE channel, it says the transfer mode is “DMA if available”. Does that mean the DMA has been enabled?

How do i keep the cd drive installed?

Thanks again for your help

“DMA if available” doesn’t mean that DMA is enabled.

Check the BIOS settings for drive and IDE/DMA settings, then use Devicemanager again to re-install the drive.

Thanks for getting back to me.

Where do i check the BIOS settings? Is that in Devicemanager? And do i check for drive settings and IDE/DMA settings for the cd drive in ‘properties’?

Thanks for your help

BIOS from the mobo. Normally you have to press DEL or F2 to get into the BIOS when your computer starts up.