Problem with Mainconcept mpeg encoder

vbimport

#1

I´m using Mainconcept 1.04.01.00 with serial number, not demo.
Sony Vegas Video 5 Registered.
I´m encodind as MPEG2 SVCD files.

I´m encoding video with the Mainconcept MPEG encoder and the problem i have is that with every video i encode, when i see it, it appears a square on the top right corner made of 9 little squares. Looks like a logo but it isn´t.
It happens the same when i´m rendering my edited videos with Vegas 5 using Mainconcept MPEG2 to MPEG2 SVCD files.

If anyone knows something about it…tell me.

Thanks.


#2

Hi,

I had the same problem about 3 years ago. But how you can encounter the same prob beats me. Because what you have indicated is that it is the logo of the free version of Elecard Mpeg2 decoder. If everything is registered as you say, Windows and any other software player should use the registered Mpeg2 decoder and not the elecard Mpeg2 version. My suggestion is uninstall the Elecard decoder. If this is not directly possible than find out the dll which the Elecard decoder is registered by on your comp and then maually uninstall(unregister) it. Please find out how to do this on the Web(Google).

Thanks.
Unicorn23’.


#3

Thanks you asked me. I thought no one had the problem.

I forgot to tell that I had installed a previous version of the Mainconcept MPEG encoder 1.00 that was a Demo. I found a serial number, it worked but the word demo on the program never disapear. That´s why I installed a newer version registered. Before i installed the newer version i unistall the old one. As you know the problem persists. Probably the solution is what you told me but i tried to do it and I couldn´t. Could you explain me with more details how to solve the problem. Sorry for my ignorance. Thanks.


#4

Hi,

Now do exactly as I say.

  1. Uninstall the registered version of your Mpeg Encoder. Note down the serial number prior to uninstall.
  2. Then uninstall the any Mpeg decoders and encoders which are present on your machine including Elecard’s which is the only one I know of which displays Nine squares in the top corner. As mentioned previously try doing this via programs menu Uninstall(preferred) or do this manually(never if you do not know how) via Hardware Device Manager by first identifying the dll(from Google) which belongs to the free Mpeg2 Decoder and manually removing it in the Video Compression Codecs section.
  3. Then Re-Install the Registered Mpeg Encoder version back.
    Now it should never display the logo again.

Hope this helps.
Unicorn23’.

P.S. Never install anything which calls itself free without first finding out what else it does after it is free.


#5

I did as you told me, I uninstalled Mpeg decoders and encoders doing this via programs menu Uninstall. I uninstalled the two i had, Adobe Premiere Mpeg encoder and Mainconcept Mpeg encoder. I could´t find any encoder named Elecard.

I had installed vegas 4 before i installed vegas 5 and had the same problem Rendering.

I unistalled the decoders and with Vegas 5 and Vegas 4 i still can render to Mpeg with Mainconcept Mpeg encoder and find the same problem, so i tried to uninstall manually but i couldn´t do it. Which i don´t understand.

This are all the files that i have in the Video Compression Codecs section:( i looked in Google but i couldn´t find the one i have to delete).

  • DivX 5.1.1 Codec
  • iccvid.dll
  • indeo video 5.10
  • ir32_32.dll
  • ir41_32.ax
  • iyuv_32.dll
  • msh261.drv
  • msh263.drv
  • msrle32.dll
  • msvidc32.dll
  • msyuv.dll
  • tsbyuv.dll

thanks again.


#6

Hi,

Okay here’s what I think is wrong. You do not have elecard’s mpeg2 Decoder displayed in the post. So either of the following is happening:

  1. The Adobe or mainconcept Mpeg Encoders are installing a demo version of the Elecard Mpeg2 Decoder(mpgdec.dll/mpgdec.ax). After installing the mainconcept encoder you could manually unregister this file(mpgdec.ax) in c:/windows/system32 and uninstall and delete it from system(just rename it to mpgdec.bak).
    OR
  2. TRY THIS FIRST----The dll is still present on your system and you just don’t know it. So search for it and delete it and install Mainconcept(my advice forget Adobe).
    OR
  3. Either Toshiba Video Codec(tsbyuv.dll), Divx, Indeo Video or iccvid.dll is a problem coz’ one of these is not registered or rather is a demo version and thus introduces the logo. Please check using Google.

Hope this helps.
Unicorn23’


#7

Well at last problem solved !!!

The funny thing is that i don´t know what was the exact problem.

The steps I´ve done:

  • Uninstall Adobe Premiere ánd all the plugins(encoders decoders)
  • Uninstall divx codecs
  • Uninstall divx players
  • Uninstall Intervideo WinDVD Player
  • Uninstall Intervideo WinDVD Creator

What I found out is:

  • the problem wasn´t the encoding process was at reproducing the file. But only the files I encoded. The Mpeg files I downloaded from the web, at reproducing them, they did´t show that damm nine squares logo. I noticed this playing the files i encoded (before solving the problem), now with the problem solved they don´t show any logo that they sowed before. So I don´t know what was it.

  • The other thing is that I´ve installed Mainconcept encoder 1.4 again, but Vegas Video 4 uses Mainconcept MPEG encoder 1.0 And Vegas Video 5 uses version 2.0.
    I don´t know how to make them use vers 1.4. Probably eeach codec comes with the programs. Anyway I´m gonna use Vegas Video 5 with encoder vers. 2.0 that is ok.

Unicorn23’ THANK YOU VERY MUCH for your patience and your time !

Rouch.


#8

Hi,

I’m sorry you misunderstood. What I meant was that the mpeg2 codec as mentioned in the previous post is utilised(called like a subroutine) only when an mpeg2 file is encountered. Otherwise the directshow filters of Windows can usually handle any other files(i.e.mpegs-ordinary mpeg1). So if the files you “downloaded” were NOT mpeg2 then the logo would never be displayed as the mpeg2 codec would never be used for those files but since the ones you encoded for DVD are definitely mpeg2 the codec would be used to play those as directshow does not handle these mpeg2 files( just as it does not handle divx avis which are instead handled by the divx codec). I hope i have explained it better now.

Unicorn23’