Problem with liteon SHOW-1673S

vbimport

#1

I’ve had a liteon SHOW-1673S drive for about 4 months now and I haven’t had any issues. But yesterday I tried changing my booktype setting to DVD-ROM using booktype 1.35 but I always get the message “Unsupported Drive Detected!”

I also tried to use omnipatcher to change my writing strategy for the RITEKG05 but when I open omnipatcher everything is grayed out.

I’m using the lastest Firmware (JS0B official) and I was wondering if any of you could be of assistance.
Thanks in advance


#2

I’ve just tried KProbe. When I use the ASPI driver there is no drives showing up so I use the STPI drivers. If I do info Drive KProbe2 close without any messages…


#3

Use 2.4.2 version of KProbe, 2.4.3 does the same to me.


#4

ASPI is grayed out because you (probably) haven’t got the ASPI layer installed. That’s a common issue in Windows XP, where the layer isn’t installed while installing the system. You can get the ASPI layer here.

BTW : Recommended sequence is (yeah, it’s recommended by me, but I did this and everything’s all right now) dumpaspi, killaspi, instaspi.


#5

The “Unsupported Drive Detected!” message is probably been displayed because you are using NVidia IDE drivers. Use the roll back driver button under Device manager to revert to the MCP driver to fix this.

Re omnipatcher - you must use the unscrambled firmware on our site with OmniPatcher(see my signature). Stock is the the same as official (just not scrambled).


#6

you can keep your nforce ide driver, but you need to physicly remove your aspi layer with killaspi!!!
I had the same issu before and I noticed that sweetching to STPI without totally removing the Aspi layer doesn’t always cure.


#7

Thanks it worked. On an other problem I did a scan and my burst rate is at
6,25MiB/s. I can’t find it again but I’ve read that I am supposed to get a burst rate of 20+MiB/s anyone know what could cause the problem?

[quote=“C0deKing”]

The “Unsupported Drive Detected!” message is probably been displayed because you are using NVidia IDE drivers. Use the roll back driver button under Device manager to revert to the MCP driver to fix this.
[/QUOTE}

Well, I have an NForce4 Motherboard and I think I installed the nvidia IDE Drivers. Though when I go in the drive property and I do a rollback it doesn’t work. It says I’m using driver version 5.1 of Microsoft corporation. If I go in drivers details I see this:

cdrom.sys
GEARAspiWDM.sys
imapi.sys
pfc.sys
PxHelp20.sys
redbook.sys
storprop.dll

Oh… :smiley: Sorry about that thanks for clearing that up :smiley:

Since I mentionned multiple issues I’m wondering wich issue you are talking about. If its about the booktype setting not working well before trying that I’ve heard Nero install his own aspi driver. Will Nero stop working if I use killAspi?

My current ASPI drivers (According to aspichk.exe) are:


aspi32.sys     version 4.6 (1.021)
wowpost.exe version 4.6 (1.021)
winaspi.dll     version 4.6 (1.021)
wnaspi.dll      version 4.6 (1.021)

Thanks again for your help :smiley:


#8

No!! Your nero aspi will keep on working. Only adaptec aspi layer will be removed, and yes this will fix your bitsetting issue.


#9

After recently trying the latest 5.1 NVidia drivers I am now recommending the removal of the the NVidia IDE driver as they cause more problems then they are worth. The NVidia NForce MCP2 IDE driver that is loaded before the NVidia SCSI IDE driver is much better and in some cases faster - so by using the rollback it will revert to the MCP2 driver, whereas uninstalling the NVidia IDE driver will make it revert to the Microsoft driver.


#10

Well my problem is rollback didn’t work. Its probably because I have nforce4. Maybe they don’t install NVidia NForce MCP2 IDE drivers now.


#11

Interesting. So under device manager in the IDE ATA/ATAPI controllers, you double clicked on the IDE controller and on the driver tab clicked the rollback button - what happened? Did it revert to the MS drivers?


#12

Check your ide controller in device manager, it should be dma mode 4. You should be getting around 40 mb/s.


#13

Actually, anything above 23MB/s is acceptable :wink:


#14

In my IDE ATA/ATAPI controlers I have 3 things
NVIDIA CK804 ADMA Controler (V2.7)
NVIDIA CK804 ADMA Controler (V2.7)
NVIDIA CK804 Parallel ATA Controller (v2.7)

If I do A rollback on the PATA (I think thats what IDE Is) It ask me to install NForce4 Parallel ATA Controller.

The driver file it use is the nvatabus.sys and idecoi.dll

Maybe I should try getting alternative drivers somewhere else? if so where can I get those MCP2 drivers?

Check your ide controller in device manager, it should be dma mode 4. You should be getting around 40 mb/s

There is no places whatsoever to set the DMA mode or even read it.


#15

I’ve found that someone suggested doing an “Update driver” instead of Rollback. And it indeed worked. I now have the better 2001 Microsoft drivers and I’m getting burst rate of 40MB/s and I can change my booktype setting :D. Finally. Now I just need to change my writing strategy for my RITEKG05 And I’M good to go :smiley: