Problem with Liteon 160p6s model

vbimport

#1

I recently purchased a Liteon 160p6s DVD burner. The drive works but only with about 50% of my DVDs. With the other 50% the DVDs won’t even read. The green light stays on and that’s it.
I use only original DVDs without scratches. The DVDs that don’t work in the burner work fine on a regular DVD player. Is there a known problem with the firmware or do I just have a faulty drive?

Thanks
Herbert


#2

It shouldn’t be giving you those problems, but it won’t hurt to update your firmware and only takes a few seconds and a reboot. Here’s a link to the latest official firmware for your drive - http://www.liteonit.com/DOWNLOADS/ODD/SHW-160P6S/firmware/DR16PS09.zip

If you are interested in some of the newer features such as HyperTuning that improve burn quality, you can download one of the latest test firmwares posted in this forum. That’s what I’m using and, combined with the SmartBurn Utility that allows HyperTuning and Online HyperTuning as well as faster burn speeds beyond the rated disc speed, I’ve been happy with the improvements it has provided.


#3

I’ve had a similar problem with a 160P6S I supplied to a friend. Note that this is a problem reading commercially-pressed DVDs, not just home-recorded ones, and on my friend’s 160P6S it would not read some DVDs pressed by Sony DASD in Austria.

My previous experience with LiteOn drives has been that they would read CDs and DVDs that other makes would not. Unless LiteOn fix this problem with the new range rapidly I won’t be recommending or fitting any more of their drives, it would ruin my reputation as well as theirs.


#4

Thanks for the pointers. I will update the firmware and see if it does anything.
The funny thing is:
I have a DVD set of Star Trek Voyager in NTSC format. There are 7 DVDs in the set. First 2 DVDs won’t read, the third and fourth work perfectly, fifth and sixth won’t etc.
The same with a DVD set of three DVDs in PAL format. First two won’t read, the third reads perfectly.
Very, very frustrating…


#5

To exclude a faulty drive, can you try to install it on a different computer? If it work on a different machine with the same discs, then is a problem in your pc.


#6

The problem seems to be solved. The firmware update did it. Thanks to Scoobiedoobie for the tip. I’m glad, now I can watch my shows :slight_smile:


#7

Glad to hear that worked. To be honest, it was kind of a long shot to have that work, but there was no harm in trying and you will get better performance out of your drive with the newer firmware anyway. If you are interested in the latest test firmware, it’s been working well for me and the added features in the test version of Liteon’s SmartBurn Utility has improved the burn quality and allows higher burn speeds as well. If you are interested, the versions to get are firmware PV8P and Smartburn 3.1.16t. They are in the forum here, look in the test firmware and test Smartburn threads for the links.