Problem with Lite-On LTR-52327S

vbimport

#1

I have two Lite-On LTR-52327S internal cd-rw drives, both bought within a month of each other in late 2003. They are first generation drives with an EEPROM chip. One drive was used at home, and one at work. Both drives were upgraded several times without incident to the latest Lite-On firmware, the last time being in January of this year. This February-March, my home (first) drive began having serious trouble reading or writing any of my discs. I brought the work drive home and used it without incident for a few weeks before it too began behaving the same way.

The problem I’m having is after you insert any disc, the drive will spin up really fast, spin back down, and then you can briefly hear the laser mechanism jerk before it repeats this process several times until it finally successfully reads the data off the disc. I can eventually read my data, but I can no longer successfully burn a cdrom or use my cd-rw media.

Can I do anything to repair or restore proper operation to these drives? Thank you.


#2

Have you tried cleaning the lens?


#3

No I have not. All I have done is blown some compressed air inside with the tray out. In the past, when I’ve tried using drive cleaners, they’ve done nothing to help. I will go ahead and buy a drive cleaning kit and try it, although I doubt that both drives are suffering from a dirty lens. Any recommendations on a good drive cleaning kit?


#4

Another possibility is that your home computer killed the drives. You did say that the other drive was just fine until a few weeks after bringing it home. This can happen if the power supply of the computer is unstable. It doesn’t happen very often, but it has happened to people on the forum, so that could be a possibility… shrug