Problem with LITE-ON DVDRW SOHW-1693S

i tried to flash KSOB and it wouldnt work, it said contact my vendor, im now trying codeguys…

Hi :slight_smile:
joshleafe,
You can also make your drive ‘region free’ with LtnRPC utility .

also KC4B is now saying unable to flash firmware :frowning:

That’s really odd…try zebadee’s link above :slight_smile:

ltnrpc also says
set DVD region failed

I’m out of ideas, this is a very strange problem :frowning:

noo! dont give up on me :frowning: lol

would the fact that i have nvidia dvd decoders installed have anything to do with it?

At the moment, anything is worth a try! Try uninstalling them :iagree:

Sorry to jump in late, but I have the same burner as well.
You said your current fw is KS04? Have you ever had a bad or incomplete flash?

Hi :slight_smile:
I’d check all connections + try uninstalling your 1693 via device manager. Then reboot & let Windows reinstall drive.
On the question of f/w I notice there’s a 1693SX. I don’t have the drive but have you tried this f/w also? It has the same ID.

yes, all of the flash’s have been incomplete or have had errors

Thanks for the extra input guys :iagree:

i have just opened up my system and there is one cable the is in the dvd-+rw and not in my motherboard, i think it might be my audio cable?
im restarting my system now to reinstall it…

yes thanks everyone for your help, hopefully this problem will be resolved soon :slight_smile:

I dunno. If this fails as well,…
Arachne, zebadee…do you think it’s time for something like MtkFlash?

nope, i still cant flash the firmware and it still isnt playing my dvd’s

That’s what I was trying to remember…I could just remember the name of it, but not how to use it, having never had a bad flash myself. Might be an idea :eek:

i really dont know what to do anymore :sad:

Hold tight, hopefully MaineMan or zebadee will come up with the MtkFlash wisdom :slight_smile:

ok lets just sit and wait for a miracle :stuck_out_tongue: