Problem with LG GGC-H20L and Sil3114 SATA controller

vbimport

#1

[qanda]This thread is about the LG GGC-H20L. Click here to see full specs[/qanda]Hello,

I am having a very difficult problem with my new LG GGC-h20L blu-ray etc. drive. I put it in my machine, and for 1 day it worked perfectly. Then, it quit recognizing dvd, blu-ray and hd-dvd discs. After reading the other threads about this drive, it seems it does not play nice with some SATA chipsets. I am running an AMD 690G (asus m2-vm board).

To try and address that problem I purchased a SYBA SD-SATA-4P PCI SATA Controller Card (Silicon Image 3114 chipset), flashed it to the IDE bios (shows as SATALink in device manager) and installed the LG drive. Still the same issue, can read CDs but not other optical media.

The drive can read CDs after a while, but no dvds, blu-ray or hd-dvd. Any thoughts, or is it just a bad drive?

Thanks,
Matt


#2

Matt,

Is there any error code when you try DVD, BD, HD DVD?

Try running Cyberlink BDAdvisor (download here) and please post a screenshot. It will show your hardware and software needed to examine and troubleshoot your problem.


#3

Nope, no error code. Simply nothing happens, the light flashes on the front, stops eventually, but when double-clicking to open the drive in explorer it just says there is no disc. This happens w/ data DVDs as well, so it cant be the UDF driver issue (though I believe Vista has this included anyways).

Screenshots:

Also of note, I dont plan to play BR movies with this PC. The goal is to create a movie jukebox to play on my PS3 of the discs I own.

Thanks!


#4

Clicked the [i] in the last row?


#5

Yea, my monitor does not support HDCP. However, this should not affect the ability of the drive to read a data dvd, would it? Or just browse the contents of a blu-ray disc? Thats the problem I am having.


#6

Try downloading Blu-ray UDF driver in my sig and let us know if it works.


#7

OK, I installed that driver, but no luck. Same result as before, will not recognize dvd or blu-ray.

I am using Vista, so I should have a UDF driver already. I had to install this one in XP compatability mode, but it did install.

Thanks for assisting me!