Problem with GSA-H20N

Hello everyone!
I’ve a big prolem with my gsa-h20n dvdrw drive and recently even with the cdrw drive which is making me mad,so I thought this forum is the best place I can ask my question.Here is the problem:
I can’t read anything,dvd or cd,with both the dvd drive and the cd drive with more than 1.4x!!!My cpu load is 50% while copying files(since I have a dual core cpu,the cpu load doesn’t go higher than 50%) and copying a full dvd takes around 35mins,its the same about making images.Yesterday I updated the firmware of my dvd drive to 1.02,to all my surprise,everything became OK after that,I could copy with 16x but after a shutdown,it became as it was :sad: !I should also say that after that shutdown,I reconnected my cdrw drive to the machine(I’d removed it for the updating process) but removing that again didn’t fix the problem.And when I wanna write on a cd,nero says the write speed is 52x,but the writing takes 6mins,so the speed isn’t 52x for sure!I’d be really glad if someone helps me!Thanks.

First check the dma of your drives ( optical and hard drives ). Look here how to do that. http://club.cdfreaks.com/showthread.php?t=101616

That’s it,well here are some pictures:


I believe the first one is my HDD,but the second one shows my cdrw and dvdrw drive and they’ve both been set to PIO only!So now I think I should ask why this has happened?Is the problem from the drives or the mobo or maybe even the cable?And if I put it back to DMA mode,will it return to PIO only after a restart?Thanks for your help again!

When you already know they are in PIO mode, why don’t you just set it to DMA instead of asking why does it happen? Set it to DMA, Reboot, you get the answer of your last question :wink:

I didn’t!!If zhadoom hadn’t told me,I would have never found it out!After updating the firmware,in fact the dvdrw had been reinstalled and that’s why I could read dvds with the right speed right after the update(I found it out after reading the thread zhadoom recommended).I wanna know why it went back to PIO only mode after one restart?There must be a problem that this is happening again and again!Well,you’re all PROs here and I’m just a beginner,that’s why I’m asking so many questions,I wanna know what’s happening! :confused:

This can happen because after the firmware upgrade the id of the drive changes and the windows reinstall it. It depends of the driver and the chipset used in motherboard.

But now you know how to proceed if this happen again. :bigsmile:

Does it shows it’s working in DMA after you changed it?

If you had a bad/scatched DVD that is so hard for the DVD drives to read, Windows will set them to PIO mode and try to read them as hard as it can. Avoid heavily bad/scratched discs, it shouldn’t automatically goes back to PIO. I’ve read this at somewhere in this forum. Good luck!

I think I know what has caused this,some time ago,I bought some princo dvds,they were supposed to be 8x as written on the dvd,but they were 4x,and I had much problem writing on or reading from them,god knows who makes these stuff where I live,cause the real company would never write 8x on 4x dvds!Anyway,thank you PROs!!! :bigsmile:

I just changed the transfer mode to DMA if available,then hit the OK and went back again to see if it has been changed.The transfer mode was,but the current transfer mode was still PIO only,I thought It might need a restart,but that didn’t fixed it either!I unistalled both the cdrw and the dvdrw and restarted,they were found again but the current transfer mode is still PIO only while I have set the transfer mode to DMA if available!It seems windows is not gonna change it,so,now what? :sad:

Guys,aren’t you gonna help me?What should I do now?How can I force windows to set the “current transfer mode” to DMA mode?I’ve set the “transfer mode” to DMA if available but windows doesn’t change the “current transfer mode” to DMA mode! :sad:

OK. I’m out of ideas but…

  • Check if the IDE cable isn’t damaged. If possible replace them for a new flat ultraDMA133 80wire cable
  • Check the BIOS for the transfer mode of both drives.
  • Verify if you have a vendor especific driver installed and update it or uninstall and replace by standard microsoft IDE drives ( if possible )
  • If nothing good happens try to disconnect one of the drives and see if the remaining goes to DMA mode

I’m guess that the most probable cause is driver or hardware conflict.

Good luck. :bigsmile:

Oh god,at last it worked!This time,I uninstalled the whole IDE channel,and after rebooting,the IDE channel and both drives were installed again and set to Ultra DMA mode 2!!!Now I can read everything at the right speed thanks to you all!
There is only a minor problem left,2 IDE cables were in my mobo’s box,one labeled as “HDD cable” and the other one as “CD-ROM cable”.My mobo has 2 IDE ports.One of them doesn’t support atapi devices,so I have to connect the dvdrw and the cdrw to the other IDE port and as written in the mobo’s manual,I should use the cable with colored IDE connections (which is the HDD cable) on that IDE port (the IDE connections of the CD-ROM cable are black)!!!
So,does it make any difference with which of these cables I connect my cdrw and dvdrw drives to the mobo?

I guess you have an ASUS mobo?
If you have two differently labeled IDE cables you should watch out: HDD cable is always 80-wire (up to UDMA4) and CD-ROM cable may be 40-wire. To be safe, use the HDD cable :wink:

Yes,you’re right,I have a P5W DH and at the moment I’m using the one labeled as “HDD cable”,so I think I should keep using it!!!:smiley:
Thanks.

And one last question,both my drives are set to ultra DMA mode 2 and my 160gb SATA hdd,to ultra DMA mode 5,but as I asked one of my friends who has a sony dvdrw drive and an old 60gb IDE hdd,he said his dvdrw is set to ultra DMA mode 4 and his hdd to ultra DMA mode 6!!!So,how can I know which dma mode is the right mode for each devise?Thanks for your help! :clap:

If I remember correctly H20N is capable of UDMA4 if you use a 80 wire IDE cable. If you use a 40 wire IDE cable the drive negotiate a UDMA2 speed with IDE controller. For 16x write the 40 wire cable is sufficient.

UDMA6 is found only in SATA drives or ATA-133 ( some Maxtor and Samsung HDs).

As I said,I’m using the HDD cable (the one which came with the mobo) to connect my dvdrw to the mobo,and as kg_evilboy said,the HDD cable must be a 80 wire cable,so,you don’t wanna tell me there is still sth wrong although as you said,I can already read and write everything @ 16x!

Well,that’s exactly where the problem is,my friend has and old 60gb IDE HDD,and I wonder how his HDD is set to UDMA6!!!And he told me that he can change the DMA mode in the mobo’s bios!So should I also look for the same stuff in my bios?

Although My problem is already solved and I owe you all a big thank,but since I’m a newbie,I wanna learn as much as I can from you PROs!!! :bigsmile:

If it ain’t broke, don’t fix it.