Problem with enabling usb 2.0 on motherboard

vbimport

#1

Hi,

Is anyone familiar with FIC motherboards? Specifically the FIC VI13L.
It is supposed to have USB 2.0. When i connected my flash drive i got a
pop-up saying the usb was not an enhanced port.
The device manager shows 3 SiS 7001 PCI to USB Open Host Controller and 3
USB Root Hub but no Enhanced Host Controller.
I loaded the driver disc and tried to install a USB 2.0 inf patch but i get a
error message box saying: Devices -536870389 update device driver for plug and play.
I tried to uninstall the USB in the device mgr then restart and tried the patch again but I get the same error.
I’m not sure whate the error means and i havent found anything related to that error in google.
I have the latest BIOS update SAN41.

Thanks,
RmF


#2

You don’t say which operating system you have. My USB 2 weren’t recognised as 2 but 1.1 until I installed SP1 on XP.


#3

i have windows xp pro with service pack2.

RmF


#4

Hi,

I managed to get the enhanced controller installed.
I went to usbman website and found a usb tips and tricks page for the
SiS 7001 host controller.
When i changed some settings in the BIOS listed in the website, I got a “Windows was not shutdown properly” message. I tried the start windows normally option but I got the same message.
I started windows in safemode and uninstalled the USB Root Hubs and Host controllers.
When I restarted I went and reset all my BIOS settings. The computer started ok and the Enhanced controller is listed in the device manager.
The device driver file version is microsoft 5.1.2600.2180 xpsp_sp2_rtm 040803_2158.
I’m thinking I probably didnt need to mess with my BIOS settings in the first place; just installing the patch in safemode might have fixed it.

RmF