Problem with dw1610

i bought a benq dw1610 16x dvd rewriter dual format drive yesterday and installed it, i then burned a disc and at the very end it said burn process failed but i checked the disc and it worked fine. then i went to burn another disc at 40x (disc supports up to 52x) it took 2 mins to do 20% whereas usually it would take that to do 80% on my old dvd writer, but while it was burning the used read buffer dropped right down and then went back up (using nero 6.6), i then tried using sonic now and burned a disc but came up with burn failed at the end, this time the last 2 tracks did not work! anyone got any ideas? this never happened before with my old drive!

  • just tried again at 32x this time it worked but took 10 mins where usually it takes 3 mins at 24x speed on my old writer! should i clear the nero cache and reinstall it? if so how do i clear the cache? *

Probably, the DMA of the IDE connecting to the 1620 is not yet turned on. You must enable it. Also, it is better to flash the latest firmware for the benq writer.

just checked and it says dma enabled if available so it must be!!

What brand of media are you using?